Bazaar Version Control System

Bazaar halts and silently expects input from STDIN

Reported by Daniel Clemente on 2008-07-06
10
Affects Status Importance Assigned to Milestone
Bazaar
Undecided
Unassigned
bzr-dbus
Undecided
Unassigned

Bug Description

When doing some operations, Bazaar halts and only resumes the operation after I press ENTER four times. This happens each time with several actions like branch, update or merge.

  From strace it is clear that it expects some input since it halts here:

writev(4, [{"l\1\0\1\0\0\0\0\3\0\0\0\203\0\0\0\1\1o\0%\0\0\0/org/ba"..., 152}, {"", 0}], 2) = 152
gettimeofday({1215364774, 69831}, NULL) = 0
poll([{fd=4, events=POLLIN, revents=POLLIN}], 1, 0) = 1
read(0,

   I attach a longer version of the last part of strace. I will also attach the debug with pdb.

   The bug seems related to dbus.

   My system is Debian GNU/Linux unstable with following packages (all latest versions):
- python-dbus 0.82.4-2
- bzr-dbus 0.1~bzr35-4
- dbus 1.2.1-2
- libdbus-glib-1-2 0.76-1
- python2.5 2.5.2-7
- this happens both with bzr 1.5 and with bzr-dev from today

Daniel Clemente (n142857) wrote :
James Westby (james-w) wrote :

Hi,

Thanks for the bug report. It looks related to bzr-dbus as you say,
so I have added a task for the plugin. Could you please confirm that
running with --no-plugins makes this go away?

Thanks,

James

Daniel Clemente (n142857) wrote :

Yes, adding --no-plugins makes this work, as you said. Tested with 1.5 and today's code.

Changed in bzr:
status: New → Invalid
Changed in bzr-dbus:
status: New → Confirmed
Robert Collins (lifeless) wrote :

There isn't anything in bzr-dbus that seems likely to cause this. Can you try to:
 - reproduce the bug
 - remove *just bzr-dbus*
 - try to reproduce again.

If that fixes it, then it does sound like bzr-dbus *or* something connected via bzr-dbus, *or* something in the python-dbus you are running.

Changed in bzr-dbus:
status: Confirmed → Incomplete
Daniel Clemente (n142857) wrote :

I can't reproduce it anymore with bzr-dbus 0.1~bzr36-3, python-dbus 0.83.0-1 and bzr 1.5-1.1 (all are the latest on Debian unstable). I guess this bug can be closed until it affects someone again.

 status invalid

(because it hasn't been fixed... just gone)
--
GPG key available at: <http://www.robertcollins.net/keys.txt>.

Jelmer Vernooij (jelmer) on 2012-02-01
Changed in bzr-dbus:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers