bzr-svn causes bzr pull to crash

Bug #229848 reported by Tomáš Myšík on 2008-05-13
Affects Status Importance Assigned to Milestone
Bazaar Subversion Plugin
Jelmer Vernooij

Bug Description

If I try to pull from repo, bzr crashes. Please note that the repo URL is definitely correct. If I unistall bzr-svn plugin, everything works.

Using saved location:
bzr: ERROR: svn.core.SubversionException: ("Repository moved permanently to ''; please relocate", 175011)

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/bzrlib/", line 846, in run_bzr_catch_errors
    return run_bzr(argv)
  File "/usr/lib/python2.5/site-packages/bzrlib/", line 802, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib/python2.5/site-packages/bzrlib/", line 504, in run_argv_aliases
  File "/usr/lib/python2.5/site-packages/bzrlib/", line 660, in run
  File "/usr/lib/python2.5/site-packages/bzrlib/", line 111, in open
    return control.open_branch(_unsupported)
  File "/usr/lib/python2.5/site-packages/bzrlib/", line 1397, in open_branch
    return, _found=True)
  File "/usr/lib/python2.5/site-packages/bzrlib/", line 1160, in open
  File "/usr/lib/python2.5/site-packages/bzrlib/", line 583, in find_repository
    found_repo = self._find_containing(usable_repository)
  File "/usr/lib/python2.5/site-packages/bzrlib/", line 559, in _find_containing
  File "/usr/lib/python2.5/site-packages/bzrlib/", line 774, in open_containing_from_transport
    result = BzrDir.open_from_transport(a_transport)
  File "/usr/lib/python2.5/site-packages/bzrlib/", line 733, in open_from_transport
    return, _found=True)
  File "/usr/lib/python2.5/site-packages/bzrlib/", line 1598, in open
    return self._open(transport)
  File "/usr/lib/python2.5/site-packages/bzrlib/plugins/svn/", line 71, in _open
    return remote.SvnRemoteAccess(transport, self)
  File "/usr/lib/python2.5/site-packages/bzrlib/plugins/svn/", line 41, in __init__
    _transport = get_svn_ra_transport(_transport)
  File "/usr/lib/python2.5/site-packages/bzrlib/plugins/svn/", line 87, in get_svn_ra_transport
    return SvnRaTransport(bzr_transport.base)
  File "/usr/lib/python2.5/site-packages/bzrlib/plugins/svn/", line 119, in convert
    raise convert_error(e)
SubversionException: ("Repository moved permanently to ''; please relocate", 175011)

bzr 1.4 on python 2.5.2 (linux2)
arguments: ['/usr/bin/bzr', 'pull']
encoding: 'UTF-8', fsenc: 'UTF-8', lang: 'cs_CZ.UTF-8'
  bzrtools /usr/lib/python2.5/site-packages/bzrlib/plugins/bzrtools [1.4.0]
  diffstat /home/gapon/.bazaar/plugins/diffstat [unknown]
  docdiff /home/gapon/.bazaar/plugins/docdiff [0.9.0]
  gtk /usr/lib/python2.5/site-packages/bzrlib/plugins/gtk [0.94.0]
  launchpad /usr/lib/python2.5/site-packages/bzrlib/plugins/launchpad [unknown]
  lessdiff /home/gapon/.bazaar/plugins/lessdiff [unknown]
  lesslog /home/gapon/.bazaar/plugins/lesslog [unknown]
  qbzr /home/gapon/.bazaar/plugins/qbzr [0.9.0]
  rebase /usr/lib/python2.5/site-packages/bzrlib/plugins/rebase [0.2.0]
  stats /home/gapon/.bazaar/plugins/stats [unknown]
  svn /usr/lib/python2.5/site-packages/bzrlib/plugins/svn [0.4.9]
  xmloutput /home/gapon/.bazaar/plugins/xmloutput [0.4.3]
*** Bazaar has encountered an internal error.
    Please report a bug at
    including this traceback, and a description of what you
    were doing when the error occurred.

Tomáš Myšík (gapon) wrote :

I tried bzr-svn 0.4.10 and even trunk - no change.

gapon wrote:
> I tried bzr-svn 0.4.10 and even trunk - no change.
Does it work if you use "bzr pull --no-plugins ..." ?

If it does, this is a bzr-svn bug. If it doesn't this is a bzr bug
(since bzr will show the error message raised by the last branch format
it tries to open the URL with).



Tomáš Myšík (gapon) wrote :

> Does it work if you use "bzr pull --no-plugins ..." ?

As I wrote - if I uninstall bzr-svn, everything is back to normal.

James Westby (james-w) wrote :


That would seem to confirm that it is a bzr-svn problem



Changed in bzr:
status: New → Invalid
Jelmer Vernooij (jelmer) on 2008-06-23
Changed in bzr-svn:
assignee: nobody → jelmer
milestone: none → 0.4.11
status: New → Fix Committed
Jelmer Vernooij (jelmer) on 2008-07-28
Changed in bzr-svn:
importance: Undecided → Medium
Jelmer Vernooij (jelmer) on 2008-08-09
Changed in bzr:
status: Invalid → Fix Released
Jelmer Vernooij (jelmer) on 2008-08-09
Changed in bzr-svn:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers