bzr commit breaks after bzr st when a directory with file(s) has become a symlink

Bug #228234 reported by James Troup on 2008-05-08
4
Affects Status Importance Assigned to Milestone
Bazaar
Low
Unassigned

Bug Description

| $ mkdir test; cd test
| $ mkdir foo bar; touch foo/bar
| $ bzr init; bzr add -q; bzr commit -m .
| Committing to: /home/james/scratch/test/
| added bar
| added foo
| added foo/bar
| Committed revision 1.
| $ rm -fr foo; ln -s bar foo; bzr st
| removed:
| foo/bar
| kind changed:
| foo (directory => symlink)
| $ bzr commit -m .
| Committing to: /home/james/scratch/test/
| modified foo
| deleted foo/bar
| bzr: ERROR: An inconsistent delta was supplied involving 'foo/bar', 'bar-20080508145408-eg1atyhtjx51p1w2-3'
| reason: This was marked as a real delete, but the WT state claims that it still exists and is versioned.
| zsh: exit 3 bzr commit -m .
| $

Interestingly, the 'bzr st' is required, if you don't run that, 'bzr
commit' won't explode.

We originally saw this with bzr 1.3 from Ubuntu 8.04 but have
reproduced it with 1.4 from the bzr PPA.

Vincent Ladeuil (vila) wrote :

This a variation of bug #205636, with the same work around: bzr st.

James Troup (elmo) wrote :

Err, sorry for the confusing double negative, let me try again.

In my example, if you run 'bzr st', it breaks as described.
If you don't run 'bzr st', it works.

So, I don't think 'bzr st' is a work around for this bug(, unless you're suggesting not running it as a work around.)

Vincent Ladeuil (vila) wrote :

Thanks for pointing this, yes, I misread the report.

Indeed in bug #205636 bzr st *is* required. All kind changes are not equal for bzr...

The motivation of the comment was to link the two bugs together as they both involve a kind change. That part still aplies :)

Vincent Ladeuil (vila) on 2008-09-29
Changed in bzr:
importance: Undecided → Low
status: New → Confirmed
status: Confirmed → Triaged
Martin Pool (mbp) wrote :

May be similar to bug 303954

Martin Pool (mbp) on 2010-03-19
Changed in bzr:
status: Triaged → Confirmed
Vincent Ladeuil (vila) wrote :

I can't reproduce this bug with bzr-2.0.1 nor bzr-dev, if you still can, please re-open.

Changed in bzr:
milestone: none → 2.0.6
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers