info -v fails over bzr+ssh

Bug #208869 reported by Mathieu Charron on 2008-03-29
2
Affects Status Importance Assigned to Milestone
Bazaar
High
Andrew Bennetts

Bug Description

doing a remote info command on a launchpad branch:
bzr info -v bzr+ssh://bazaar.launchpad.net/~elwillow/+junk/igb-api
Standalone branch (format: unnamed)
Location:
  branch root: bzr+ssh://bazaar.launchpad.net/%7Eelwillow/%2Bjunk/igb-api/

Format:
       control: bzr remote bzrdir
        branch: Remote BZR Branch
    repository: bzr remote repository

Branch history:
         0 revisions
bzr: ERROR: exceptions.KeyError: 'committers'

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/bzrlib/commands.py", line 834, in run_bzr_catch_errors
    return run_bzr(argv)
  File "/usr/lib/python2.5/site-packages/bzrlib/commands.py", line 790, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib/python2.5/site-packages/bzrlib/commands.py", line 492, in run_argv_aliases
    return self.run(**all_cmd_args)
  File "/usr/lib/python2.5/site-packages/bzrlib/commands.py", line 800, in ignore_pipe
    result = func(*args, **kwargs)
  File "/usr/lib/python2.5/site-packages/bzrlib/builtins.py", line 1118, in run
    verbose=noise_level, outfile=self.outf)
  File "/usr/lib/python2.5/site-packages/bzrlib/info.py", line 343, in show_bzrdir_info
    outfile)
  File "/usr/lib/python2.5/site-packages/bzrlib/info.py", line 376, in show_component_info
    stats = _show_branch_stats(branch, verbose==2, outfile)
  File "/usr/lib/python2.5/site-packages/bzrlib/info.py", line 276, in _show_branch_stats
    committers = stats['committers']
KeyError: 'committers'

bzr 1.3 on python 2.5.1.final.0 (linux2)
arguments: ['/usr/bin/bzr', 'info', '-v', 'bzr+ssh://bazaar.launchpad.net/~elwillow/+junk/igb-api']
encoding: 'UTF-8', fsenc: 'UTF-8', lang: 'en_CA.UTF-8'
plugins:
  gtk /usr/lib/python2.5/site-packages/bzrlib/plugins/gtk [0.93.0]
  launchpad /usr/lib/python2.5/site-packages/bzrlib/plugins/launchpad [unknown]
*** Bazaar has encountered an internal error.
    Please report a bug at https://bugs.launchpad.net/bzr/+filebug
    including this traceback, and a description of what you
    were doing when the error occurred.

here is the bzr --version:
Bazaar (bzr) 1.3
  Python interpreter: /usr/bin/python 2.5.1.final.0
  Python standard library: /usr/lib/python2.5
  bzrlib: /usr/lib/python2.5/site-packages/bzrlib
  Bazaar configuration: /home/elwillow/.bazaar
  Bazaar log file: /home/elwillow/.bzr.log

John A Meinel (jameinel) wrote :

I am unable to reproduce this with bzr.dev, can you try upgrading to 1.4? (I was also unable to reproduce it with 1.3, but that is probably 1.3.1)

Changed in bzr:
status: New → Incomplete
Andrew Bennetts (spiv) wrote :

I can confirm this. It happens when using "info -v" over HPSS.

Changed in bzr:
assignee: nobody → spiv
importance: Undecided → High
milestone: none → 1.8
status: Incomplete → Confirmed
Andrew Cowie (afcowie) wrote :

Just FYI, this does not occur with a bzr:// URL:

$ bzr info -v bzr://research.operationaldynamics.com/bzr/java-gnome/mainline

works no problem. So either Launchpad is screwed, or it's bzr+ssh:// specific.

AfC

Andrew Bennetts (spiv) wrote :

Interesting. I can reproduce it with a local bzr:// server, using bzr.dev on both client and server:

bzr init /tmp/blah
cd /tmp/blah
bzr serve &
bzr info -v bzr://localhost/

So it's a real bug in bzr.dev.

What version of bzr do you have on the server?

Martin Pool (mbp) on 2009-06-26
Changed in bzr:
milestone: 1.8 → none
Andrew Bennetts (spiv) wrote :

I can' t reproduce this anymore, I guess this got fixed a while ago. Feel free to reopen or file a new bug if you are still having trouble!

Changed in bzr:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers