bzr export trips assertion if directory contains nested branches

Bug #197897 reported by nwf on 2008-03-03
2
Affects Status Importance Assigned to Milestone
Bazaar
Medium
Unassigned

Bug Description

bzr will let you create nested branches, ala:

nwf@smaug:~/tmp$ bzr init-repository bzrtest2
nwf@smaug:~/tmp$ cd bzrtest2/
nwf@smaug:~/tmp/bzrtest2$ ls
nwf@smaug:~/tmp/bzrtest2$ bzr init outer
nwf@smaug:~/tmp/bzrtest2$ bzr init inner
nwf@smaug:~/tmp/bzrtest2$ cd outer/
nwf@smaug:~/tmp/bzrtest2/outer$ bzr branch ../inner
Branched 0 revision(s).
nwf@smaug:~/tmp/bzrtest2/outer$ ls
inner

However, running "bzr export outer_export outer" in bzrtest2 will result in
bzr: ERROR: exceptions.StopIteration:

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/bzrlib/commands.py", line 806, in run_bzr_catch_errors
    return run_bzr(argv)
  File "/usr/lib/python2.4/site-packages/bzrlib/commands.py", line 762, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib/python2.4/site-packages/bzrlib/commands.py", line 492, in run_argv_aliases
    return self.run(**all_cmd_args)
  File "/usr/lib/python2.4/site-packages/bzrlib/builtins.py", line 2097, in run
    export(t, dest, format, root)
  File "/usr/lib/python2.4/site-packages/bzrlib/export/__init__.py", line 97, in export
    return _exporters[format](tree, dest, root)
  File "/usr/lib/python2.4/site-packages/bzrlib/export/__init__.py", line 61, in _loader
    return func(tree, dest, root)
  File "/usr/lib/python2.4/site-packages/bzrlib/export/dir_exporter.py", line 40, in dir_exporter
    entries.next() # skip root
StopIteration

bzr 1.1.0.candidate.1 on python 2.4.4.final.0 (linux2)
arguments: ['/usr/bin/bzr', 'export', 'oe', 'outer/']
encoding: 'UTF-8', fsenc: 'UTF-8', lang: 'en_US.UTF-8'
plugins:
  launchpad /usr/lib/python2.4/site-packages/bzrlib/plugins/launchpad [unknown]
  multiparent /usr/lib/python2.4/site-packages/bzrlib/plugins/multiparent.pyc [unknown]
*** Bazaar has encountered an internal error.
    Please report a bug at https://bugs.launchpad.net/bzr/+filebug
    including this traceback, and a description of what you
    were doing when the error occurred.

Full version information:
$ bzr --version
Bazaar (bzr) 1.1.0.candidate.1
  Python interpreter: /usr/bin/python 2.4.4.final.0
  Python standard library: /usr/lib/python2.4
  bzrlib: /usr/lib/python2.4/site-packages/bzrlib
  Bazaar configuration: /home/nwf/.bazaar
  Bazaar log file: /home/nwf/.bzr.log

Copyright 2005, 2006, 2007 Canonical Ltd.
http://bazaar-vcs.org/

bzr comes with ABSOLUTELY NO WARRANTY. bzr is free software, and
you may use, modify and redistribute it under the terms of the GNU
General Public License version 2 or later.

Martin Pool (mbp) on 2008-04-30
Changed in bzr:
importance: Undecided → Medium
John A Meinel (jameinel) wrote :

I can't reproduce this with the latest bzr version, so I'm guessing it has been fixed.

I do see the error with bzr 1.3. However, I don't believe it is because of the nested branch, but instead because you've never done "bzr commit" in either branch (so there are no committed revisions.)

There have been a few patches recently which effect export code, the specific error here doesn't happen with bzr.dev, so should be fixed in bzr1.7

Changed in bzr:
milestone: none → 1.7
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers