bzr 1.1 dapper PPA debs FTBFS

Bug #189915 reported by James Troup
4
Affects Status Importance Assigned to Milestone
Bazaar
Critical
Martin Pool

Bug Description

The bzr 1.1 dapper package in PPA build-depends on python-central which doesn't exist in dapper.

Revision history for this message
LaMont Jones (lamont) wrote :

Here are the patches I applied to get it to build on dapper.

Note that edgy adds python-all-dev, python-all-dbg didn't arrive until feisty.

Revision history for this message
LaMont Jones (lamont) wrote :

And for bzrtools

Revision history for this message
LaMont Jones (lamont) wrote :

Also, ISTR that there was a python-central event, and the build-depends: python-central should have a version attached to it... someone with python-central clue could answer that.

Revision history for this message
Martin Pool (mbp) wrote :

How on earth did it build in the PPA if the build-dependency package doesn't exist?

Changed in bzr:
assignee: nobody → mbp
importance: Undecided → Critical
milestone: none → 1.2
status: New → Confirmed
Revision history for this message
Martin Pool (mbp) wrote :

OK, apparently it didn't build, but see bug 191703.

Martin Pool (mbp)
Changed in bzr:
status: Confirmed → In Progress
Revision history for this message
Christopher Armstrong (radix) wrote :

I was pointed to this ticket about dapper+bzr packages not working, but I'm not sure if my problem is the same. At least, it seems the problem is not *just* python-central; it's also python2.5 (which isn't in Dapper at all) and libc versions. Here's what's happening:

radix@ubuntu:~$ sudo apt-get install bzr
Reading package lists... Done
Building dependency tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  bzr: Depends: libc6 (>= 2.7-1) but 2.3.6-0ubuntu20 is to be installed
       Depends: python (> 2.5) but 2.4.2-0ubuntu3 is to be installed or
                python-celementtree but it is not installable
       Depends: python-central (>= 0.5.50) but it is not installable
E: Broken packages
radix@ubuntu:~$

Revision history for this message
Martin Pool (mbp) wrote :

radix, can you tell me if that problem is still occurring with the current build?

Changed in bzr:
status: In Progress → Incomplete
Revision history for this message
Martin Pool (mbp) wrote :

I believe this is now fixed, please reopen it if there is still a problem.

Changed in bzr:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers