2.42-2.6b1 Windows standalone GUI does not open

Bug #1837281 reported by james connolly on 2019-07-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Undecided
Unassigned

Bug Description

I used to run the 2.6b1 standalone windows GUI without problems, the problem may have started after i installed MinGW or Python 3.7. I also tried the 2.5.1 and 2.4.2 standalone versions and got similar (or possibly even the same) errors. If I try to start the GUI from a cmd console, I get the following output, the logfile is attached.

C:\jamie\Perple_X>bzr explorer ./
Qt: Untested Windows version 6.2 detected!
C:/Program Files (x86)/Bazaar/plugins\explorer\lib\desktop_env.py:158: DeprecationWarning: bzrlib.win32utils._ensure_unicode was deprecated in version 2.5.0.
bzr: ERROR: bzrlib.util.configobj.configobj.ParseError: Invalid line at line "1".

Traceback (most recent call last):
  File "bzrlib\commands.pyo", line 930, in exception_to_return_code
  File "bzrlib\commands.pyo", line 1141, in run_bzr
  File "bzrlib\commands.pyo", line 673, in run_argv_aliases
  File "bzrlib\commands.pyo", line 697, in run
  File "bzrlib\cleanup.pyo", line 136, in run_simple
  File "bzrlib\cleanup.pyo", line 166, in _do_with_cleanups
  File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\commands.py", line 162, in run
  File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\explorer.py", line 208, in __init__
  File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\wt_browser.py", line 49, in __init__
  File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\wt_browser.py", line 450, in __init__
  File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\wt_browser.py", line 685, in __init__
  File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\wt_browser.py", line 628, in __init__
  File "C:/Program Files (x86)/Bazaar/plugins\qbzr\lib\treewidget.py", line 1331, in __init__
  File "C:/Program Files (x86)/Bazaar/plugins\qbzr\lib\revtreeview.py", line 61, in __init__
  File "bzrlib\lazy_import.pyo", line 116, in __call__
  File "bzrlib\lazy_import.pyo", line 85, in _resolve
  File "bzrlib\lazy_import.pyo", line 200, in _import
  File "C:/Program Files (x86)/Bazaar/plugins\qbzr\lib\diff.py", line 49, in <module>
  File "C:/Program Files (x86)/Bazaar/plugins\qbzr\lib\util.py", line 128, in get_option
  File "C:/Program Files (x86)/Bazaar/plugins\qbzr\lib\util.py", line 109, in _load
  File "bzrlib\util\configobj\configobj.pyo", line 1223, in __init__
  File "bzrlib\util\configobj\configobj.pyo", line 1306, in _load
ParseError: Invalid line at line "1".

bzr 2.6b1 on python 2.6.6 (Windows-post2008Server-6.2.9200)
arguments: ['bzr', 'explorer', './']
plugins: bzrtools[2.5.0], changelog_merge[2.6b1], colo[0.4.0],
    explorer[1.3.0dev], fastimport[0.14.0dev], git[0.6.8dev],
    launchpad[2.6b1], loom[2.3.0dev], netrc_credential_store[2.6b1],
    news_merge[2.6b1], pipeline[1.4.0], qbzr[0.23.0dev], rewrite[0.6.4dev],
    svn[1.2.2dev], upload[1.2.0dev], xmloutput[0.8.8]
encoding: 'cp1252', fsenc: 'mbcs', lang: None

*** Bazaar has encountered an internal error. This probably indicates a
    bug in Bazaar. You can help us fix it by filing a bug report at
        https://bugs.launchpad.net/bzr/+filebug
    including this traceback and a description of the problem.

C:\jamie\Perple_X>

james connolly (jamesconnolly) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments