BZR_SSH should allow setting the path to ssh, not just the kind of ssh

Bug #176292 reported by Martin Pool on 2007-12-14
4
Affects Status Importance Assigned to Milestone
Bazaar
Undecided
Martin Packman

Bug Description

In 1.0 BZR_SSH can be "paramiko", "plink", "ssh" etc to say what kind of ssh client you want to use. However, there's no apparent way to give the command or path to use.

This is a problem because
1- it's inconsistent with cvs, rsync, etc use of *_SSH
2- some people may not want to use the implementation on their path and want to specify the full path

However, we do need to also know what vendor it is, to know what argument syntax to use amongst other things. The command name alone is probably not enough because openssh and f-secure ssh are both called "ssh" but have different option meanings. So we might need BZR_SSH_VENDOR.

It might be useful if these were also available as configuration variables.

Also, the variable is barely documented, and should be properly explained.

Related branches

Daniel Hahler (blueyed) on 2008-03-12
Changed in bzr:
status: New → Confirmed
Martin Packman (gz) wrote :

Merged in r4809

Changed in bzr:
assignee: nobody → Martin [gz] (gz)
status: In Progress → Fix Committed
Changed in bzr:
status: Fix Committed → Fix Released
milestone: none → 2.1.0b4
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers