AttributeError: 'module' object has no attribute 'install_lazy_compile'

Bug #1657238 reported by Stefan Husmann on 2017-01-17
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Bazaar
High
Vincent Ladeuil

Bug Description

With commit 6620

[haawda@frege bazaar]$ bzr revno
Traceback (most recent call last):
  File "/usr/bin/bzr", line 74, in <module>
    import bzrlib
  File "/usr/lib/python2.7/site-packages/bzrlib/__init__.py", line 131, in <module>
    bzrlib.lazy_regex.install_lazy_compile()
AttributeError: 'module' object has no attribute 'install_lazy_compile'

Similar message for bzr branch.

This is under Arch Linux with python2 2.712 or python 2.7.13.

Related branches

Vincent Ladeuil (vila) wrote :

What version of bzr are you using ?

This could have been caused by a recent fix but that would require using a very old python version which doesn't match your description.

summary: - bzr does not work
+ AttributeError: 'module' object has no attribute 'install_lazy_compile'
Changed in bzr:
status: New → Incomplete
Stefan Husmann (stefan-husmann) wrote :

This was tested with revision 6620 from trunk (2.8 series).

Vincent Ladeuil (vila) wrote :

/me scratches head

Could it be as simple as https://code.launchpad.net/~vila/bzr/1657238-wrong-import/ ?

I.e. can you use that branch to test again and report if that fixes your issue ?

Vincent Ladeuil (vila) wrote :

Wow, there were two issues in the backported debian patch (fixed in the branch mentioned above).

I still don't understand what issue you're encountering though.

It looks like your python version is ... unsual as if the fix works it should mean your python's re module doesn't have a finditer method which was introduced in python 2.2...

So it would help if you could report the output of:

BZR_DEBUG=1 bzr revno

that may provide a bit more info about which path is triggering that AttributeError.

Stefan Husmann (stefan-husmann) wrote :

BZR_DEBUG=1 bzr revno
6620

Vincent Ladeuil (vila) on 2017-01-30
Changed in bzr:
status: Incomplete → Confirmed
importance: Undecided → High
assignee: nobody → Vincent Ladeuil (vila)
milestone: none → 2.7.1
Vincent Ladeuil (vila) on 2017-01-30
Changed in bzr:
status: Confirmed → In Progress
Vincent Ladeuil (vila) on 2017-01-30
Changed in bzr:
status: In Progress → Fix Released
bzr PQM (bzr-pqm) on 2017-01-30
Changed in bzr:
status: Fix Released → Fix Committed
Stefan Husmann (stefan-husmann) wrote :

Thanks, indeed it seems to work now.

MrJOHN (johntin1988) on 2017-02-21
Changed in bzr:
status: Fix Committed → In Progress
status: In Progress → Fix Committed
MrJOHN (johntin1988) on 2017-02-21
Changed in bzr:
status: Fix Committed → In Progress
status: In Progress → Fix Committed
Jelmer Vernooij (jelmer) on 2017-05-30
Changed in bzr:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers