Fails to build with diffutils 3.5

Bug #1622039 reported by Colin Watson on 2016-09-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Medium
Vincent Ladeuil
Breezy
Medium
Unassigned

Bug Description

diffutils 1:3.5-1 in Debian unstable includes the following change:

  * Exit status of diff for binary files that differ is now 1, not 2,
    as mandated by POSIX. Closes: #737180.

This causes the Bazaar test suite to fail:

======================================================================
FAIL: bzrlib.tests.test_diff.TestDiffFiles.test_external_diff_binary
----------------------------------------------------------------------
Traceback (most recent call last):
testtools.testresult.real._StringException: Empty attachments:
  log

Traceback (most recent call last):
  File "/<<BUILDDIR>>/bzr-2.7.0+bzr6619/build/lib.linux-x86_64-2.7/bzrlib/tests/test_diff.py", line 317, in test_external_diff_binary
    self.assertEqual(2, pipe.returncode)
  File "/<<BUILDDIR>>/bzr-2.7.0+bzr6619/build/lib.linux-x86_64-2.7/bzrlib/tests/__init__.py", line 1370, in assertEqual
    pprint.pformat(a), pprint.pformat(b)))
AssertionError: not equal:
a = 2
b = 1

Related branches

Vincent Ladeuil (vila) wrote :

No user impact but since using '2' for binary was a bug upstream and that no code in bzr appears to rely on that (confirmed by the single failure), the test should be fixed to stop checking for this value.

Changed in bzr:
importance: Undecided → Medium
milestone: none → 2.7.1
status: New → In Progress
Vincent Ladeuil (vila) on 2016-09-09
Changed in bzr:
assignee: nobody → Vincent Ladeuil (vila)
Vincent Ladeuil (vila) on 2016-09-11
Changed in bzr:
milestone: 2.7.1 → 2.8b1
bzr PQM (bzr-pqm) on 2017-01-17
Changed in bzr:
status: In Progress → Fix Committed
Jelmer Vernooij (jelmer) on 2017-05-30
Changed in brz:
status: New → Fix Released
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers