Test failure: hexify removed from paramiko

Bug #1480015 reported by Andrew Starr-Bochicchio on 2015-07-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Medium
Andrew Starr-Bochicchio
bzr (Debian)
Fix Released
Unknown
bzr (Ubuntu)
High
Unassigned

Bug Description

Forwarding from Debian:

bzr FTBFS in the current sid:

  ERROR: bzrlib.tests.test_transport.TestSSHConnections.test_bzr_connect_to_bzr_ssh
  [...]
    File "/tmp/buildd/bzr-2.6.0+bzr6602/build/lib.linux-x86_64-2.7/bzrlib/transport/ssh.py", line 334, in connect_ssh
      t = self._connect(username, password, host, port)
    File "/tmp/buildd/bzr-2.6.0+bzr6602/build/lib.linux-x86_64-2.7/bzrlib/transport/ssh.py", line 292, in _connect
      server_key_hex = paramiko.util.hexify(server_key.get_fingerprint())
  AttributeError: 'module' object has no attribute 'hexify'

Upstream paramiko removed this function in
<https://github.com/paramiko/paramiko/commit/1970abbdf2f587e5>.

Related branches

Changed in bzr:
status: New → In Progress
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
importance: Undecided → Medium
Changed in bzr (Debian):
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr - 2.6.0+bzr6602-2ubuntu4

---------------
bzr (2.6.0+bzr6602-2ubuntu4) wily; urgency=medium

  * debian/patches/11_use_binascii_hexlify.patch: Take patch from merge
    proposal by Andrew Starr-Bochicchio to fix FTBFS due to removed 'hexlify'
    method in paramiko. (LP: #1480015)

 -- Iain Lane <email address hidden> Mon, 05 Oct 2015 13:33:56 +0100

Changed in bzr (Ubuntu):
status: New → Fix Released
Changed in bzr (Ubuntu):
importance: Undecided → High
Changed in bzr (Debian):
status: Confirmed → Fix Released
Vincent Ladeuil (vila) on 2016-01-21
Changed in bzr:
milestone: none → 2.7b1
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.