config tests related warnings on stderr breaks autopkgtest'ing

Bug #1331999 reported by Vincent Ladeuil on 2014-06-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Medium
Vincent Ladeuil

Bug Description

Reported by pitti on IRC:

<pitti> vila: bzr fails on the various stderr spam (https://jenkins.qa.ubuntu.com/view/Utopic/view/AutoPkgTest/job/utopic-adt-bzr/1/ARCH=i386,label=adt/console) and doesn't declare "allow-stderr"
<pitti> vila: is that stderr expected and considered "normal" (and thus we should add allow-stderr), or considered an indication of a bug?

<vila> pitti: hmm, you mean the stderr output needs to be declared or the test fails ? Those messages... are caused by a minor bug... with annoying ramifications. I have a fix though but I never submitted it because I thought I was the only one observing it...

<vila> pitti: it's a test-only bug for that matter
<pitti> vila: yes, by default stderr is considered a failure, mostly to catch unexpected warnings and such

<vila> pitti: and to better understand, is this new ?
<pitti> vila: the stderr output is new, yes; fail-on-stderr has always been the case

Related branches

Vincent Ladeuil (vila) on 2014-06-19
Changed in bzr:
status: In Progress → Fix Committed
Vincent Ladeuil (vila) on 2014-06-20
Changed in bzr:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers