better explanation of import process

Bug #130573 reported by Martin Pool on 2007-08-06
2
Affects Status Importance Assigned to Milestone
Bazaar
Low
Unassigned

Bug Description

There are several ways you can get an import from an existing cvs or svn branch into Bazaar. We should give a better explanation of them on the web site. In this approximate order:

0- talk to us
1- conversion on launchpad
2- cvsps - may not be deterministic
3- if you have an svn repo, use bzr-svn
4- svn2bzr - intended for one direction, one-off conversions. Any remaining advantages over bzr-svn?

Martin Pool (mbp) on 2007-08-06
Changed in bzr:
importance: Undecided → Low
status: New → Confirmed

On Mon, 2007-08-06 at 03:41 +0000, Martin Pool wrote:
> Public bug reported:
>
> There are several ways you can get an import from an existing cvs or svn
> branch into Bazaar. We should give a better explanation of them on the
> web site. In this approximate order:
>
> 0- talk to us
> 1- conversion on launchpad
> 2- cvsps - may not be deterministic
> 3- if you have an svn repo, use bzr-svn
> 4- svn2bzr - intended for one direction, one-off conversions. Any remaining advantages over bzr-svn?
svn2bzr creates deterministic revision ids so doesn't necessarily have
to be used for one-off conversions, using it incrementally also works.

"bzr svn-import" from bzr-svn and svn2bzr basically have the same
functionality, except:

* svn2bzr does proper renames rather than delete+add.
* bzr-svn can use local or remote repositories and svn dump files,
svn2bzr only works with svn dump files
* bzr-svn can guess the branching scheme

I'm very confident about the stability of bzr-svn's import functionality
and last time I checked svn2bzr also worked very well (though I haven't
tested it on a wide range of repositories, maybe Gustavo can comment on
that?)

Cheers,

Jelmer

John A Meinel (jameinel) wrote :

Isn't this sort of information already covered in:

http://bazaar-vcs.org/TrackingUpstream

Or are you thinking that we need a doc in the bzr codebase?

John A Meinel (jameinel) wrote :

To respond to Jelmer:

is 'svn2bzr' "deterministic" or "stable" ? (If 2 people convert, do they get identical results, or can you just incrementally update the conversion).

My concern is that you can manually edit your svn dump file (many people intentionally do this so that they can remove portions of their history they don't want. Like that accidental check-in of an ISO).

If the dump has been filtered, we need to be very careful to not generate the same revision ids.

Ian Clatworthy (ian-clatworthy) wrote :

This is now covered by the Data Migration Guide: http://doc.bazaar-vcs.org/migration/en/

Changed in bzr:
milestone: none → 2.1.0b4
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers