defaulting to pycurl doesn't make sense anymore

Bug #125055 reported by Jean Jordaan
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Fix Released
Medium
Jelmer Vernooij

Bug Description

bzr logged that it couldn't find pycurl, so I installed it. As a result,
ctrl-c stopped working. I asked on #bzr about this, and it turned out
that defaulting to pycurl has become sub-optimal.

<jam-laptop> [pycurl] used to be better (supported connection caching, etc)
<jam-laptop> But we have updated our urllib to support connection caching
<jam-laptop> the only real downside pycurl had was the ^C issue
<jam-laptop> but as you noticed, it is a bit of an issue :)
[...]
<jam-laptop> neaj: urllib support is now probably better than pycurl
<jam-laptop> The only thing pycurl does atm that urllib doesn't is
             validate https certificates
[...]
<jam-laptop> Though that is a mixed blessing
<jam-laptop> as people often have self-signed certificates
[...]
<jam-laptop> and pycurl will block connecting to them :)
[...]
<jam-laptop> that our urllib support has improved to the point
<jam-laptop> that it is worth not defaulting to pycurl anymore

Tags: http pycurl

Related branches

Aaron Bentley (abentley)
Changed in bzr:
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
axk (axk) wrote :

i also installed pycurl because of that log entry. now i occasionally get

  bzr: ERROR: Connection error: curl connection error (Could not resolve host: bazaar.launchpad.net (Domain name not found))

errors. disabling pycurl fixes them. so if the certificate validation is pycurls only advantage over urllib, i would +1 the suggestion here.

(bzr 0.90.0, pycurl-ssl-7.16.4.win32-py2.5)

Vincent Ladeuil (vila)
Changed in bzr:
assignee: nobody → v-ladeuil
Revision history for this message
Robert Widhopf-Fenk (hack-robf) wrote :

I just accidentally tried a

  bzr info https://bazaar.launchpad.net/~hack-robf/viewmail/trunk

which hangs and cannot be aborted by Control-C.

Is this related to this bug?

I am running latest bzr-dev, i.e. 1.2.0.dev.0 rev 3221.

Revision history for this message
Vincent Ladeuil (vila) wrote : Re: [Bug 125055] Re: defaulting to pycurl doesn't make sense anymore

>>>>> "rwf" == Robert Widhopf-Fenk <email address hidden> writes:

    rwf> I just accidentally tried a
    rwf> bzr info https://bazaar.launchpad.net/~hack-robf/viewmail/trunk

Firefox hangs too...

    rwf> which hangs and cannot be aborted by Control-C.

    rwf> Is this related to this bug?

The 'cannot be aborted by Control-C' part is.

*Why* it hangs, though, may need investigation on the server side.

Revision history for this message
Gustavo Carneiro (gjc) wrote :

I hate that bzr hangs and cannot be interrupted via Ctrl-C (not even Ctrl-4 works!).

Jelmer Vernooij (jelmer)
tags: added: http pycurl
Jelmer Vernooij (jelmer)
Changed in bzr:
assignee: Vincent Ladeuil (vila) → Jelmer Vernooij (jelmer)
status: Confirmed → In Progress
Vincent Ladeuil (vila)
Changed in bzr:
milestone: none → 2.6b1
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers