change in execute bit is ignored

Bug #399067 reported by Radim Kolář on 2009-07-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar Plugin for Eclipse
High
Piotr Piastucki
Java library for Bazaar
Medium
Piotr Piastucki
bzr-xmloutput
Undecided
Unassigned

Bug Description

C:\Documents and Settings\majitel\ganymede\crm114-tools>bzr xmlstatus
<?xml version="1.0" encoding="UTF-8"?><status workingtree_root="C:/Documents and
 Settings/majitel/ganymede/crm114-tools/"><modified><file fid="crmtrain.py-20090
627141336-fbjv1o9irdp798v3-1">crmtrain.py*</file></modified></status>

File contains also changed content (not only execute bit) but bzr-eclipse is not able to detect file change. Team -> Commit displays There is nothing to commit.

Guillermo Gonzalez (verterok) wrote :

Radim,
Thanks for reporting this issue.
I'll try to get some time fix this ASAP.

Changed in bzr-eclipse:
importance: Undecided → High
status: New → Confirmed
xaav (xaav) on 2011-07-14
Changed in bzr-eclipse:
status: Confirmed → Triaged
Changed in bzr-eclipse:
milestone: none → 1.3
Piotr Piastucki (piastucki) wrote :

There seems to be a bug in xmloutput plugin that makes the plugin append unwanted * at the end of the file name in case of files with the execute bit changed. E.g.
<?xml version="1.0" encoding="utf-8"?><status workingtree_root="/somefolder/inkscape/"><modified><file fid="authors-20091128124040-aej0x7yhxng1m6ly-2">AUTHORS*</file></modified></status>

See statusxml.py, line 274 for more details:

            if len(item) == 5 and item[4]:
                path += '*'

Instead of changing the file path it would be better to add a flag denoting changes in file permissions.

affects: bzr-eclipse → bzr-xmloutput
Changed in bzr-xmloutput:
milestone: 1.3 → none
affects: bzr-xmloutput → bzr-eclipse
Changed in bzr-xmloutput:
status: New → Confirmed
Changed in bzr-eclipse:
assignee: nobody → Piotr Piastucki (piastucki)
milestone: none → 1.3
Changed in bzr-eclipse:
status: Triaged → In Progress
Changed in bzr-xmloutput:
status: Confirmed → Fix Committed
Changed in bzr-java-lib:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Piotr Piastucki (piastucki)
milestone: none → 1.3
Changed in bzr-eclipse:
status: In Progress → Fix Committed
Changed in bzr-java-lib:
status: Fix Committed → Fix Released
Changed in bzr-eclipse:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers