bzr-svn on Windows does not support Subversion 1.6 format

Bug #405595 reported by Philip Peitsch on 2009-07-28
50
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Bazaar Windows Installers
Medium
Unassigned

Bug Description

Attempting to branch a svn working copy created using Subversion 1.6.1 results in the following error:

bzr: ERROR: This client is too old to work with working copy 'C:\working_dir\ntlmaps-svn'. You need to get a newer Subversion client, or to downgrade this working copy. See http://subversion.tigris.org/faq.html#working-copy-format-change for details.

I'm running bzr 1.17-1 windows standalone, on Windows XP.

Jelmer Vernooij (jelmer) wrote :

Afaik we're including the Subversion 1.5 libraries with the Windows installer. A newer version should probably be shipped to fix this error.

affects: bzr-svn → bzr

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Jelmer Vernooij wrote:
> Afaik we're including the Subversion 1.5 libraries with the Windows
> installer. A newer version should probably be shipped to fix this error.
>
> ** Project changed: bzr-svn => bzr
>

So the main issue with that, is if you bundle newer subversion libs, it
auto-upgrades the checkouts to the latest version when you work with them.

I don't have a good feeling about upgrading someones SVN checkout to 1.6
because they used bzr-svn, when their local svn client is only 1.5.

I think it would be good to have the option, but it would be *better* to
do that as a bzr-svn-1.6 extra installer, rather than forcing it always.

What I would *really* like to see is a chained installer that had
options for dependencies, but I'm not a good enough installer guru to
figure that out.

John
=:->

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (Cygwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAkpvJtAACgkQJdeBCYSNAAMBDQCfbiZ4O+xVNcJ56OzUhSpCLfSD
PvcAnjoN+AtyFkL58AtqBAV2sql183Ii
=s0nX
-----END PGP SIGNATURE-----

Daniel Hahler (blueyed) wrote :

Is there a workaround?

(Previously, I've copied DLLs from the Subversion client to Bazaar's "lib" directory, but it does not work with svn 1.6.5 and bzr 1.18.1: bzr.exe now "just crashes")

drewkeller (drew-drewkeller) wrote :

This bug is a bit of a pain.

I am using bzr 2.0.0rc2 (windows standalone) which comes with addon svn 0.6.5

I tried Daniel's method above with various DLLs from a subversion installation and a TortoiseSVN installation. The first time, I tried it, bzr crashed and after that, it gives me an error with a message that it can't start subvertpy.

The workaround to init the bzr project is to move all of the .svn subfolders out of the project when initializing for bzr. But of course, there is no SVN-BZR integration when doing this. So the other way to do it is to uninstall the svn integration (requires removal and reinstallation of bzr).

Jelmer Vernooij (jelmer) wrote :

I think we should just include the newer version of Subversion; the same issue is already present when people have checkouts that were created with svn 1.1 - svn 1.5 will also upgrade them.

John A Meinel (jameinel) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Jelmer Vernooij wrote:
> I think we should just include the newer version of Subversion; the same
> issue is already present when people have checkouts that were created
> with svn 1.1 - svn 1.5 will also upgrade them.
>

Sure, it is just a timing thing. At what point do we expect most users
have upgraded to version X such that it is not a big annoyance.

Probably by now is about a reasonable time to switch. That said, I think
actually doing the switch is going to be non-trivial. I don't know what
amount of the api has changed, nor the new locations, nor if it will
impact the build process, etc.

I don't think I'll get the time to look into it before 2.0.1/2.1.0b1
which should be next week. Will anyone else have time?

John
=:->

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (Cygwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAkrPaZAACgkQJdeBCYSNAAOuUACguBOoYo86VtnCHvwtbEhOzXix
F8cAn3aAMAmw/UzokrY9HmQZtyI25Jf7
=lYQc
-----END PGP SIGNATURE-----

Jelmer Vernooij (jelmer) wrote :

On Fri, 2009-10-09 at 16:49 +0000, John A Meinel wrote:
> Jelmer Vernooij wrote:
> > I think we should just include the newer version of Subversion; the same
> > issue is already present when people have checkouts that were created
> > with svn 1.1 - svn 1.5 will also upgrade them.
> Sure, it is just a timing thing. At what point do we expect most users
> have upgraded to version X such that it is not a big annoyance.
I understand it's hard to find the right moment. It reminds me why it's
good that Bazaar doesn't do auto-upgrades :-)

> Probably by now is about a reasonable time to switch. That said, I think
> actually doing the switch is going to be non-trivial. I don't know what
> amount of the api has changed, nor the new locations, nor if it will
> impact the build process, etc.
At least in terms of API it *should* be trivial, subvertpy already
builds fine against other version of Subversion on Linux.

Cheers,

Jelmer

Daniel Hahler (blueyed) wrote :

@drewkeller:
> So the other way to do it is to uninstall the svn integration (requires removal and reinstallation of bzr).

Do you mean this is a workaround? How would you have bzr-svn integration afterwards?!

Changed in bzr:
status: New → Confirmed
drewkeller (drew-drewkeller) wrote :

It's a workaround for getting BZR to initialize a folder that contains SVN folders. Uninstalling the SVN integration removes BZR's complaints about the SVN folders but it also removes BZR's integration with SVN.

drewkeller (drew-drewkeller) wrote :

Perhaps an option can be added so the user can select what version of SVN a project contains? I'm not entirely sure how that would affect the DLLs... perhaps the different versions can go in different plugin folders?

kilroo (weston-geek) wrote :

If this isn't ready to go into a regular release, or to be provided as a drop-in replacement perhaps, is there at least anyone who could point those of us who feel daring in the right direction to figure out how we might be able to build subvertpy against svn 1.6 on our own? I started trying to figure that out and...uh...apparently I don't know what I'm doing.

John A Meinel (jameinel) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

kilroo wrote:
> If this isn't ready to go into a regular release, or to be provided as a
> drop-in replacement perhaps, is there at least anyone who could point
> those of us who feel daring in the right direction to figure out how we
> might be able to build subvertpy against svn 1.6 on our own? I started
> trying to figure that out and...uh...apparently I don't know what I'm
> doing.
>

Here is a pointer, though probably not a great one.

Get the latest windows installer code

bzr branch lp:bzr-windows-installer

Look at the file "tools/win32/buildout.cfg" this defines what files are
downloaded, etc for the build.

Take particular note of:

> svn-dev-url =
> http://subversion.tigris.org/files/documents/15/45228/svn-win32-1.5.6_dev.zip
> svn-lib-url =
> http://subversion.tigris.org/files/documents/15/45222/svn-win32-1.5.6.zip
> svn-db4-url =
> http://subversion.tigris.org/files/documents/15/32472/db-4.4.20-win32.zip
> svn-libintl-url =
> http://subversion.tigris.org/files/documents/15/20739/svn-win32-libintl.zip

Edit those to point at whatever files are appropriate for svn 1.6.*

Look at the Makefile under "installer-all-in-one". If you have cygwin,
you can just run:

  make PYTHON=/cygdrive/c/Python25/python.exe

And it should build the installer from scratch. Note that you'll
probably need quite a few dependencies to get this working completely.
(Stuff like 'cog' and InnoScript, and ...)

The actual build of subvertpy looks like it just requires:

set SVN_DEV=${buildout:directory}/${svn-dev:destination}
set SVN_BDB=${buildout:directory}/${svn-db4:destination}
set SVN_LIBINTL=${buildout:directory}/${svn-libintl:destination}

python setup.py install -O1

If you want a bit of assistance, if you can find the appropriate URLs
for svn 1.6, I'm willing to try a test build on our build host, since
I'm sure to have the rest of the dependencies available.

John
=:->

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (Cygwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAkrhwfEACgkQJdeBCYSNAAPgTQCglbleUAUNlytWq4YwCUr73/BA
rtkAmwf6a+DAwGO/NkkUhSNeVJMhRI/7
=ZVns
-----END PGP SIGNATURE-----

kilroo (weston-geek) wrote :

...Those urls look a lot like the ones linked at http://subversion.tigris.org/servlets/ProjectDocumentList?folderID=8100

Granted, at the moment, it would appear that svn 1.6.6 has been released but the new Windows binaries haven't been put up yet.

kilroo (weston-geek) wrote :

Is there any further news on this? I haven't been able to try to build this myself yet because I don't have cygwin on my computer at work...or Windows on my machine at home.

kilroo (weston-geek) wrote :

For what it's worth, the 1.6.6 binaries appear to be available now at the same link I posted before.

John A Meinel (jameinel) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

kilroo wrote:
> ...Those urls look a lot like the ones linked at
> http://subversion.tigris.org/servlets/ProjectDocumentList?folderID=8100
>
> Granted, at the moment, it would appear that svn 1.6.6 has been released
> but the new Windows binaries haven't been put up yet.
>

So I'm pretty sure that bzr-2.1.0b2 and bzr-2.1.0b3 are both build
against the bzr-svn 1.6.6 binaries. Would you care to try installing
them and see if it works for you?

John
=:->

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (Cygwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAksCy0MACgkQJdeBCYSNAAMOlgCfd2CxNsRpgE+58bUyw9zQwVhB
JT8AnAm3mxn+/okNGw2yYkVPTdnBvGxG
=5Mx/
-----END PGP SIGNATURE-----

drewkeller (drew-drewkeller) wrote :

Sure.... is there a repository somewhere with pre-built installers? The download page (http://bazaar-vcs.org/Download) doesn't have b2 or b3 yet. I use Windows Standalone.

John A Meinel (jameinel) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

drewkeller wrote:
> Sure.... is there a repository somewhere with pre-built installers? The
> download page (http://bazaar-vcs.org/Download) doesn't have b2 or b3
> yet. I use Windows Standalone.
>

https://launchpad.net/+download

has all of the installers. You can also get them directly from the
release page:
https://launchpad.net/bzr/2.1/2.1.0b3

John
=:->

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (Cygwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAksEYFYACgkQJdeBCYSNAAONLACeJrvcEq5kZMFpX3ojZf9skwuw
pn0AoJdJbB7xVuDg8ikwH/B7mVzyiCP/
=imOi
-----END PGP SIGNATURE-----

Martin Pool (mbp) on 2009-12-16
Changed in bzr:
importance: Undecided → Medium
Martin Pool (mbp) on 2009-12-16
affects: bzr → bzr-windows-installers

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Launchpad Bug Tracker wrote:
> You have been subscribed to a public bug:
>
> Attempting to branch a svn working copy created using Subversion 1.6.1
> results in the following error:
>
> bzr: ERROR: This client is too old to work with working copy
> 'C:\working_dir\ntlmaps-svn'. You need to get a newer Subversion
> client, or to downgrade this working copy. See
> http://subversion.tigris.org/faq.html#working-copy-format-change for
> details.
>
> I'm running bzr 1.17-1 windows standalone, on Windows XP.
>
> ** Affects: bzr-windows-installers
> Importance: Medium
> Status: Confirmed
>

The bzr 2.1 series should have added support for SVN 1.6+. Please upgrade.

 status fixreleased

John
=:->

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (Cygwin)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAkso/NMACgkQJdeBCYSNAAPCqQCbBXvJwl9WMwSIbSCAyMhzLSvd
H+4AnjIVdeX4mpAXbcPK2rVWF2LO4UqG
=WHou
-----END PGP SIGNATURE-----

Changed in bzr-windows-installers:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions