commit to SVN repo failed because there is no ssh client for svn libs

Bug #323548 reported by Dietmar on 2009-01-31
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar Subversion Plugin
Undecided
Jelmer Vernooij
Bazaar Windows Installers
Low
Unassigned
FreeHAL
Invalid
Critical
Unassigned
subvertpy
Fix Released
Medium
Jelmer Vernooij

Bug Description

look at the attachment

Tobias Schulz (freehal) on 2009-01-31
Changed in freehal:
importance: Undecided → Critical
status: New → Confirmed
Dietmar (webmaster-tirol4all) wrote :

A litte bit more information about the bug

bzr: ERROR: bzrlib.plugins.svn.core.SubversionException: ("Can't create tunnel: Das System kann die angegebene Datei nicht finden. ", 720002)

Traceback (most recent call last):
  File "bzrlib\commands.pyo", line 893, in run_bzr_catch_errors
  File "bzrlib\commands.pyo", line 839, in run_bzr
  File "bzrlib\commands.pyo", line 539, in run_argv_aliases
  File "C:/Programme/Bazaar/plugins\qbzr\lib\commands.py", line 695, in run
  File "bzrlib\commands.pyo", line 839, in run_bzr
  File "bzrlib\commands.pyo", line 539, in run_argv_aliases
  File "bzrlib\builtins.pyo", line 2457, in run
  File "bzrlib\builtins.pyo", line 64, in tree_files
  File "bzrlib\builtins.pyo", line 106, in internal_tree_files
  File "bzrlib\workingtree.pyo", line 333, in open_containing
  File "C:/Programme/Bazaar/plugins\svn\workingtree.py", line 812, in open_workingtree
  File "C:/Programme/Bazaar/plugins\svn\workingtree.py", line 858, in open_branch
  File "C:/Programme/Bazaar/plugins\svn\workingtree.py", line 836, in _find_repository
  File "C:/Programme/Bazaar/plugins\svn\workingtree.py", line 804, in get_remote_transport
  File "C:/Programme/Bazaar/plugins\svn\errors.py", line 152, in convert
SubversionException: ("Can't create tunnel: Das System kann die angegebene Datei nicht finden. ", 720002)

bzr 1.11 on python 2.5.2 (win32)
arguments: ['C:\\Programme\\Bazaar\\bzr.exe', 'qsubprocess', '"commit" "-m" "Update der lang_dateien" "lang_de/facts.pro.THIS" "lang_de/jeliza.pro" "lang_de/word_types.brain"']
encoding: 'cp1252', fsenc: 'mbcs', lang: None

Andrew Bennetts (spiv) wrote :

It's apparently failing because it cannot connect (I don't speak German, but "Can't create tunnel" seems clear enough).

This appears to be a bug in bzr-svn, not bzr itself. bzr-svn should not trigger a traceback simply because it cannot connect.

I don't see how this could be a bug in freehal.

  affects freehal
  status invalid

This error is caused by the fact that the Subversion installation that
comes with setup.exe doesn't include a ssh client.

  affects bzr
  status triaged
  importance low

Is "bzr" the right product for the installer?

Subvertpy could be showing a more appropriate error here, I've committed
a fix to trunk.

  affects subvertpy
  importance medium
  status fixreleased

  affects bzr-svn
  status fixreleased

--
Jelmer Vernooij <email address hidden> - http://samba.org/~jelmer/
Jabber: <email address hidden>

Changed in bzr-svn:
status: New → Fix Released
Changed in freehal:
status: Confirmed → Invalid
Jelmer Vernooij (jelmer) on 2009-09-12
Changed in bzr-svn:
assignee: nobody → Jelmer Vernooij (jelmer)
Changed in subvertpy:
assignee: nobody → Jelmer Vernooij (jelmer)
Martin Pool (mbp) on 2010-03-19
Changed in bzr:
status: Triaged → Confirmed
Jelmer Vernooij (jelmer) on 2011-02-02
affects: bzr → bzr-windows-installers
summary: - commit failed
+ commit to SVN repo failed because there is no ssh client for svn libs
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers