bzr views not supported ?

Bug #530373 reported by starenka on 2010-03-01
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Breezy
Low
Unassigned
bzr Upload plugin
Medium
Unassigned

Bug Description

It's not allways usefull to upload the whole branch. Talking about web projects one mostly have a www dir (which is synced w/ document_root on the server) and some more directories containing db schemes, docs, crons etc., which are not synced. Could uploading of cwd or just any branch subdir be implemented? Lack of this feature makes such an awsome plugin pricless for me. Thank you

starenka (starenka) wrote :

s/priceless/worthless

(sorry for my English)

Vincent Ladeuil (vila) wrote :

It looks like you want a bzr "View" here where your working tree contains only the 'www' directory.
Such a feature is better handled in bzr itself than in the bzr-upload plugin.

Changed in bzr-upload:
status: New → Won't Fix
starenka (starenka) wrote :

Hi Vincent, thanks for hint... but it seems not to work for me :(

starenka@kosmik1:/current-project$ bzr view
'just www' view is: www
starenka@kosmik1:/current-project$ bzr upload ftp://xxx:yyy@zzz/webroot/xyz
No uploaded revision id found, switching to full upload
Uploading 3rdparty/frontend/ie.css
Uploading 3rdparty/frontend/images/Thumbs.db
Uploading 3rdparty/frontend/images/content.jpg
Uploading 3rdparty/frontend/images/h-menu-left.jpg
Uploading 3rdparty/frontend/images/h-menu-left.png
Uploading 3rdparty/frontend/images/h-menu-middle.jpg

Vincent Ladeuil (vila) on 2010-03-02
Changed in bzr-upload:
importance: Undecided → Medium
status: Won't Fix → Confirmed
summary: - Upload just CWD
+ bzr views not supported ?
Jelmer Vernooij (jelmer) on 2018-08-04
tags: added: upload views
removed: wishlist
Changed in brz:
status: New → Triaged
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers