commits to http repository are empty

Bug #826946 reported by Griatch on 2011-08-15
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Bazaar Subversion Plugin
Critical
Jelmer Vernooij

Bug Description

Committing to an online svn repo (on google code) looks ok from the bazaar side -- the transfer completes and the log updates correctly, but the svn repo is not actually updated! The svn commit log is updated, but no files are actually transferred. This is also confirmed if checking out a new copy.
Bazaar remains convinced transfer went well however and refuses to further commit. There are no tracebacks on the bzr side. Only error bzr notices is when trying to commit changes to a file that was previously added (i.e. a file that bzr thought was created but actually wasn't), which returns with a bazaar error that the online file was not found in the svn repo. It's most confusing.

Tested both on 1.0.4 and 1.1.1, using bazaar 2.4b5 and 2.4.

Related branches

Griatch (griatch) wrote :

Forgot to add a link to the repo I'm using:
http://code.google.com/p/evennia/source/list

r1583 is where things start. It looks like there are a lots of files uploaded (it was an update to an old branch that was going to get some more attention), but clicking on the files in the online list reveals they are actually all empty. That's the case from there on, with the addition that the svn log doesn't even note any files as uploaded at all, only that the repo has been changed.
.
Griatch

Jelmer Vernooij (jelmer) wrote :

What do you mean with 1.1.1 (there is no such bzr-svn version) ?

Is the bzr branch available somewhere?

mvil (mvil) wrote :

Having the same problem when trying to commit to an SVN repository on sourceforge. I edit files, commit on bzr and try to dpush to the svn, but no files get changed on sourceforge.

bzr 2.3.4, bzr-svn 1.1.0dev

Jelmer Vernooij (jelmer) wrote :

mvil, is the bzr branch available somewhere? what svn URL are you pushing to?

Changed in bzr-svn:
status: New → Triaged
importance: Undecided → Critical
mvil (mvil) wrote :

Yeah actually I set up a test SVN repository of sourceforge yesterday trying to figure this out, thought maybe I was doing something to mess it up.

Here is a link to a bzr-svn commit in the repo: http://testproject124.svn.sourceforge.net/viewvc/testproject124?view=revision&revision=18
There should have been a line changed in test.txt, but nothing seems to have happened. However with bzr log -l 1 -p it does appear properly.

Push location is https://<email address hidden>/svnroot/testproject124

Only the last 2 commits are relevant, the rest is just more of the same.. Attaching the bzr branch.

Jelmer Vernooij (jelmer) wrote :

I can reproduce this against google code. I suspect it's a http-specific bug.

Jelmer Vernooij (jelmer) on 2011-08-21
Changed in bzr-svn:
assignee: nobody → Jelmer Vernooij (jelmer)
milestone: none → 1.1.0
Jelmer Vernooij (jelmer) on 2011-08-22
Changed in bzr-svn:
status: Triaged → In Progress
Jelmer Vernooij (jelmer) on 2011-08-22
summary: - Commit to svn repo completes, but repo is not updated
+ Commit to http repo completes, but repo is not updated
summary: - Commit to http repo completes, but repo is not updated
+ commits to http repository are empty
Jelmer Vernooij (jelmer) wrote :

looks like the problematic revision is r3767

Jelmer Vernooij (jelmer) wrote :

Fixed in trunk.

Changed in bzr-svn:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers