Files with non-ascii path are not pushed to svn

Bug #795994 reported by IWATA Hidetaka on 2011-06-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar Subversion Plugin
High
IWATA Hidetaka

Bug Description

This problem is in both bzr2.3.3 and bzr2.4b3

Changes in the non-ascii named folder does not pushed to SVN.

To reproduce::
  SVN repository layout
    trunk
    + テスト (non-ascii folder)

  >bzr branch url/to/svn/repos/trunk trunk
  >cd trunk

  >echo foo>テスト/foo.txt
  >bzr add
  adding "テスト/foo.txt"

  >bzr commit -m "add file to NON-ASCII folder"
  added テスト/foo.txt
  Committed revision 3.

  >bzr push url/to/svn/repos/trunk
  Pushed up to revision 3.

No errors are occurred, and the svn repository has new revision now,
but no files are in the changeset of that revision.

Related branches

Jelmer Vernooij (jelmer) wrote :

I can't reproduce this with bzr-svn trunk:

------------------------------------------------------------------------
r2 | jelmer | 2011-06-11 19:09:39 +0100 (Sat, 11 Jun 2011) | 1 line
Changed paths:
   M /trunk
   A /trunk/テスト
   A /trunk/テスト/foo.txt

add
------------------------------------------------------------------------
r1 | jelmer | 2011-06-11 19:09:00 +0100 (Sat, 11 Jun 2011) | 2 lines
Changed paths:
   A /trunk

trunk

---------------

Changed in bzr-svn:
status: New → Incomplete
IWATA Hidetaka (hid-iwata) wrote :

I've forgotten to mention about environment.
I use Windows 7, perhaps you tried to reproduce it by Linux?

It seems that dir_editor_send_changes in commit.py is wrong.
At line 366
> elif new_child_path in visit_dirs:

`visit_dirs` contains unicode values, but `new_child_path` is already encoded to utf-8.

This patch will fix it, but maybe not best solution.

Jelmer Vernooij (jelmer) on 2011-06-28
Changed in bzr-svn:
status: Incomplete → Triaged
importance: Undecided → Medium
importance: Medium → Low
importance: Low → High
Jelmer Vernooij (jelmer) on 2011-08-21
Changed in bzr-svn:
status: Triaged → In Progress
status: In Progress → Fix Committed
milestone: none → 1.1.0
assignee: nobody → IWATA Hidetaka (hid-iwata)
Jelmer Vernooij (jelmer) on 2011-08-26
Changed in bzr-svn:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers