lightweight checkout of svn repository isn't following svn-keywords rule

Bug #597887 reported by Ryan Fowler on 2010-06-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar Subversion Plugin
Low
Jelmer Vernooij

Bug Description

When I try to do a lightweight checkout of a subversion project, bzr reports that any files with an expanded $Id$ keyword are modified even though I have set up a rules file as documented. I've attached a self-contained script that does all the steps to demonstrate the problem including creating an repository with a problematic file, running svnserve, setting up a BZR_HOME with appropriate rules file, checking out a lightweight copy with bzr and running "bzr diff".

bzr diff reports that test.txt has been modified, but it hasn't.

I'm reporting this because I can't find any follow-up to Question #101615.

The script requires svn, svnadmin and svnserve to create the svn repository as well as bzr and bzr-svn. I'm using svn plugin 1.0.2.

Related branches

Ryan Fowler (rwfowler) wrote :
Jelmer Vernooij (jelmer) wrote :

I can reproduce this, but I'm not sure if it's a bug in bzr-svn or bzr itself.

Changed in bzr-svn:
status: New → Triaged
importance: Undecided → Low
Jelmer Vernooij (jelmer) on 2011-01-02
tags: added: keywords rules
Jelmer Vernooij (jelmer) on 2011-02-17
Changed in bzr-svn:
assignee: nobody → Jelmer Vernooij (jelmer)
status: Triaged → Fix Committed
Jelmer Vernooij (jelmer) on 2011-03-02
Changed in bzr-svn:
milestone: none → 1.1.0
Jelmer Vernooij (jelmer) on 2011-08-26
Changed in bzr-svn:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers