some tests from the launchpad plugin requires lazr.uri

Bug #687315 reported by Vincent Ladeuil on 2010-12-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar
Medium
Unassigned
Bazaar Mac Installers
High
Gordon Tyler
launchpadlib
Wishlist
Unassigned

Bug Description

bzrlib.plugins.launchpad.test_lp_api.TestCacheDirectory.test_get_cache_directory
bzrlib.plugins.launchpad.test_lp_api.TestDependencyManagement.test_supported_launchpadlib_version
bzrlib.plugins.launchpad.test_lp_api.TestDependencyManagement.test_get_launchpadlib_version
bzrlib.plugins.launchpad.test_lp_api.TestDependencyManagement.test_unsupported_launchpadlib_version

fails on babune for OSX 10.6 (http://babune.ladeuil.net:24842/job/selftest-osx-10.6/lastFailedBuild/testReport/)

Long story short: the launchpadlib features needed by the launchpad plugin don't require lazr.uri, but launchpadlib imports it for some other features define in the same file.

Related branches

Vincent Ladeuil (vila) wrote :

From the bzr point of view, it's enough to test for the presence of the lazr.uri module and skip the test (even if this sound weird, these are unexpected failures and add no value to the tests).

Since launchpadlib is used on platforms with no package manager, it would be nice if this was better handled by launchpadlib itself though.

Changed in launchpadlib:
importance: Undecided → Wishlist
Changed in bzr:
importance: Undecided → Medium
status: New → In Progress
assignee: nobody → Vincent Ladeuil (vila)
Vincent Ladeuil (vila) on 2010-12-08
Changed in launchpadlib:
status: New → Invalid
Changed in bzr:
status: In Progress → Invalid
Vincent Ladeuil (vila) wrote :

It turns out I was wrong in my diagnosis.

This is really a packaging bug in the osx installers: launchpadlib is only installed if the bzr-pipeline plugin is installed (it's an optional dependency there).

But the dependencies of launchpadlib itself should therefore be also taken into account:
- python-lazr.uri
- python-lazr.restfulclient
- python-simplejson
- python-httplib2
- python-wadlib
- python-oauth

This is a significant burden and we may prefer to *remove* launchpadlib in the mean time if bzr-pipeline can survive from that.

We may also want to package launchpadlib in its own subpackage with its own dependencies and makes it a requirement for bzr-pipeline once we get there.

Changed in bzr-mac-installers:
importance: Undecided → High
status: New → Confirmed
Changed in bzr:
assignee: Vincent Ladeuil (vila) → nobody
Gordon Tyler (doxxx) on 2011-01-19
Changed in bzr-mac-installers:
assignee: nobody → Gordon Tyler (doxxx)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers