Bazaar Explorer Crashes on Snow Leopard

Bug #684995 reported by Sean on 2010-12-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar Mac Installers
Medium
Gordon Tyler

Bug Description

Running 'bzr explorer' on my Snow Leopard system causes bzr to crash with the error 'no appropriate 64-bit architecture''. I was able to resolve the problem by forcing python to run in 32-bit mode with

'export VERSIONER_PYTHON_PREFER_32_BIT=yes'

I had both Qt and PyQt installed on my system, both 32-bit only, before I installed bzr. They should have only been installed for for python 2.7, which I installed separately to avoid problems with py2app and 64 bit python.

Here is the output from the explorer command:

$ bzr explorer
bzr: ERROR: exceptions.ImportError: /Library/Frameworks/QtCore.framework/Versions/4/QtCore: no appropriate 64-bit architecture (see "man python" for running in 32-bit mode)

Traceback (most recent call last):
  File "/Library/Python/2.6/site-packages/bzrlib/commands.py", line 911, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/Library/Python/2.6/site-packages/bzrlib/commands.py", line 1111, in run_bzr
    ret = run(*run_argv)
  File "/Library/Python/2.6/site-packages/bzrlib/commands.py", line 689, in run_argv_aliases
    return self.run(**all_cmd_args)
  File "/Library/Python/2.6/site-packages/bzrlib/commands.py", line 704, in run
    return self._operation.run_simple(*args, **kwargs)
  File "/Library/Python/2.6/site-packages/bzrlib/cleanup.py", line 135, in run_simple
    self.cleanups, self.func, *args, **kwargs)
  File "/Library/Python/2.6/site-packages/bzrlib/cleanup.py", line 165, in _do_with_cleanups
    result = func(*args, **kwargs)
  File "/Library/Python/2.6/site-packages/bzrlib/plugins/explorer/lib/commands.py", line 144, in run
    from bzrlib.plugins.qbzr.lib import uifactory
  File "/Library/Python/2.6/site-packages/bzrlib/plugins/qbzr/lib/uifactory.py", line 21, in <module>
    from PyQt4 import QtCore, QtGui
ImportError: /Library/Frameworks/QtCore.framework/Versions/4/QtCore: no appropriate 64-bit architecture (see "man python" for running in 32-bit mode)

bzr 2.2.0 on python 2.6.1 (Darwin-10.4.0-i386-64bit)
arguments: ['/usr/local/bin/bzr', 'explorer']
encoding: 'UTF-8', fsenc: 'utf-8', lang: 'en_US.UTF-8'
plugins:
  bash_completion /Library/Python/2.6/site-packages/bzrlib/plugins/bash_completion [2.2.0]
  bzrtools /Library/Python/2.6/site-packages/bzrlib/plugins/bzrtools [2.2.0]
  colo /Library/Python/2.6/site-packages/bzrlib/plugins/colo [0.1.0]
  email /Library/Python/2.6/site-packages/bzrlib/plugins/email [unknown]
  explorer /Library/Python/2.6/site-packages/bzrlib/plugins/explorer [1.1.0dev2]
  extmerge /Library/Python/2.6/site-packages/bzrlib/plugins/extmerge [unknown]
  fastimport /Library/Python/2.6/site-packages/bzrlib/plugins/fastimport [0.9.0dev]
  keychain /Library/Python/2.6/site-packages/bzrlib/plugins/keychain [0.1.0]
  launchpad /Library/Python/2.6/site-packages/bzrlib/plugins/launchpad [2.2.0]
  loom /Library/Python/2.6/site-packages/bzrlib/plugins/loom [2.2.1dev]
  netrc_credential_store /Library/Python/2.6/site-packages/bzrlib/plugins/netrc_credential_store [2.2.0]
  news_merge /Library/Python/2.6/site-packages/bzrlib/plugins/news_merge [2.2.0]
  pipeline /Library/Python/2.6/site-packages/bzrlib/plugins/pipeline [unknown]
  qbzr /Library/Python/2.6/site-packages/bzrlib/plugins/qbzr [0.20.0dev1]
  rewrite /Library/Python/2.6/site-packages/bzrlib/plugins/rewrite [0.6.0]
  svn /Users/sean/.bazaar/plugins/svn [1.0.4]
  upload /Library/Python/2.6/site-packages/bzrlib/plugins/upload [1.0.0dev]
  xmloutput /Library/Python/2.6/site-packages/bzrlib/plugins/xmloutput [0.8.6]

*** Bazaar has encountered an internal error. This probably indicates a
    bug in Bazaar. You can help us fix it by filing a bug report at
        https://bugs.launchpad.net/bzr/+filebug
    including this traceback and a description of the problem.

Gordon Tyler (doxxx) wrote :

When you installed Qt, it was installed as a system-level framework. Try installing the combined 32/64-bit Cocoa version of Qt: http://get.qt.nokia.com/qt/source/qt-mac-opensource-4.7.1.dmg

If you install Bazaar from the Mac OS X installer dmg, it should install the correct version of Qt for you: http://launchpad.net/bzr/2.2/2.2.2/+download/Bazaar-2.2.2-OSX-10.6-2.dmg

affects: bzr → bzr-mac-installers
Changed in bzr-mac-installers:
importance: Undecided → Medium
status: New → Incomplete
Sean (svz90) wrote :

Bazaar was installed using the Bazaar-2.2.2-OSX-10.6-1.dmg installer. I can rerun the installer if you think that will help.

Before I reinstall QT from Nokia (or from Bazaar), will installing the Cocoa 32/64 framework conflict with the installed 32-bit Carbon QT currently installed (and working with SIP/PyQt)?

Gordon Tyler (doxxx) wrote :

I think it will replace the 32-bit Carbon QT, so you would have to recompile SIP/PyQT.

I'm confused though because the installer should be installing the Cocoa 32/64-bit version and appropriately compiled versions of SIP and PyQt.

I'll investigate and see if I can reproduce the problem.

Changed in bzr-mac-installers:
assignee: nobody → Gordon Tyler (doxxx)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers