PyQt and SIP upstream provide only the latest tarballs

Bug #1046144 reported by Samuel Bronson on 2012-09-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar Mac Installers
Medium
Gordon Tyler

Bug Description

For example, the config.py file in lp:bzr-mac-installers/2.3 [1] presently has these entries for PyQT and SIP:

pyqt = {
    'name':'PyQt-mac-gpl',
    'version':'4.8.2',
    'destdir':'pyqt',
    'url':'http://www.riverbankcomputing.co.uk/static/Downloads/PyQt4/PyQt-mac-gpl-4.8.2.tar.gz',
}
sip = {
    'name':'sip',
    'version':'4.12',
    'destdir':'sip',
    'url':'http://www.riverbankcomputing.co.uk/static/Downloads/sip4/sip-4.12.tar.gz',
}

Unfortunately, it seems that riverbankcomputing.co.uk only offer tarballs for the latest release and the latest development snapshot of each package, which these aren't, so these both give 404 now.

I did manage to find copies of these versions at
    'url':'http://stavi.sh/downloads/voyeur/PyQt-mac-gpl-4.8.2.tar.gz',
and
    'url':'http://stavi.sh/downloads/voyeur/sip-4.12.tar.gz',
(guess which is which!), but I have no idea how long they'll continue to be available at those locations, so I'm not about to suggest that you merge such a patch.

Instead, I would suggest that PyQt-mac-gpl and SIP releases be archived in this project's downloads and referenced from there.

(It might be possible to use the tarballs provided by Mercurial for SIP, since those will last much longer, but I noticed that they have some files only in .in form, and I don't know how to process those...)

p.s. The URL given for the Paramiko tarball is also no longer working; ironically, it *did* refer to a VCS-based tarball (this time from github). I found the following URL on what looks like the official project website:
    'url':'http://www.lag.net/paramiko/download/paramiko-1.7.6.tar.gz',

p.p.s. If you're wondering why I'm bothering with 2.3, the reason is that that's the latest that supports OS X 10.5's Python (2.5.1), and I'm using a PowerMac and so can't upgrade to a newer version of OS X. I know it would be possible to use a third-party (is Python.org a third party?) build of Python, but I'm not sure what the installation story would look like then, especially if any of the extra batteries that Apple include (pyobjc, Twisted, turned out to be important

[1]:<http://bazaar.launchpad.net/~bzr-mac/bzr-mac-installers/2.3/view/123/config.py#L41

Gordon Tyler (doxxx) wrote :

While I can understand your situation and it bites me in the ass regularly when building installers for current versions of bzr, I don't think I should be using up Launchpad's diskspace to archive copies of pyqt and sip.

Changed in bzr-mac-installers:
status: New → Won't Fix
Vincent Ladeuil (vila) wrote :

> using up Launchpad's diskspace to archive copies of pyqt and sip.

Why not ?

After all, they are key components required to build the installers and the bzr-mac-installers project itself doesn't use download files at all.

Keeping one set for each maintained series wouldn't be a burden for lp itself IMHO.

Gordon Tyler (doxxx) wrote :

Hmm, well if you say it's alright, vila, then I guess it's okay. :)

I'll see what versions I have lying around on my Mac. I'm fairly sure I have the last versions I used to build each series.

Changed in bzr-mac-installers:
status: Won't Fix → Confirmed
importance: Undecided → Medium
assignee: nobody → Gordon Tyler (doxxx)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers