bzr-notify leaves a rogue status throbber on screen after bzr push completes

Bug #949798 reported by James Hunt on 2012-03-08
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Bazaar GTK+ Frontends
High
Curtis Hovey
bzr-gtk (Ubuntu)
Undecided
Unassigned

Bug Description

If you have bzr-gtk installed, whilst pushing a branch a small "throbber" window pops up showing some sort of push progress.

However, once the push has completed, it never goes away. Process is /usr/bin/bzr-notify and it's doing this:

$ ps -ef|grep bzr
james 4000 3748 0 08:31 ? 00:00:00 /usr/bin/python /usr/bin/bzr-notify
james 7376 1 0 08:38 ? 00:00:00 /usr/bin/python /usr/bin/bzr dbus-broadcast
james 22883 4000 0 09:35 ? 00:00:00 ssh -oForwardX11=no -oForwardAgent=no -oClearAllForwardings=yes -oNoHostAuthenticationForLocalhost=yes -l jamesodhunt bazaar.launchpad.net bzr serve --inet --directory=/ --allow-writes
$ strace -fFv -s 1024 -p 4000
Process 4000 attached with 2 threads - interrupt to quit
[pid 4605] restart_syscall(<... resuming interrupted call ...> <unfinished ...>
[pid 4000] restart_syscall(<... resuming interrupted call ...>) = 1
[pid 4000] read(6, 0xbfeb0c0c, 16) = -1 EAGAIN (Resource temporarily unavailable)
[pid 4000] recv(5, "\241 \350\23\6\0\0\4>\1\0\0K\1\0\0\366\2\0\0\6\0\0\4\0\0\0\0\0\0\0\0", 4096, 0) = 32
[pid 4000] recv(5, 0x93c4180, 4096, 0) = -1 EAGAIN (Resource temporarily unavailable)
[pid 4000] poll([{fd=5, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=5, revents=POLLOUT}])
[pid 4000] writev(5, [{"\31\0\v\0]\1\0\0\0\0\30\0! \0\0]\1\0\0>\1\0\0K\1\0\0\366\2\0\0\6\0\0\4\0\0\0\0\0\0\0\0", 44}, {NULL, 0}, {"", 0}], 3) = 44
[pid 4000] recv(5, 0x93c4180, 4096, 0) = -1 EAGAIN (Resource temporarily unavailable)
[pid 4000] recv(5, 0x93c4180, 4096, 0) = -1 EAGAIN (Resource temporarily unavailable)
[pid 4000] poll([{fd=6, events=POLLIN}, {fd=5, events=POLLIN}, {fd=7, events=POLLIN}, {fd=10, events=POLLIN}, {fd=9, events=POLLIN}], 5, -1) = 1 ([{fd=5, revents=POLLIN}])
[pid 4000] read(6, 0xbfeb0c0c, 16) = -1 EAGAIN (Resource temporarily unavailable)
[pid 4000] recv(5, "w\2\351\23\226\355=\0\3\4\4\0\0\0\0\0\0\0\0\4\4\4\4\4\0\0\3\37%\2\0\0", 4096, 0) = 32
[pid 4000] recv(5, 0x93c4180, 4096, 0) = -1 EAGAIN (Resource temporarily unavailable)
[pid 4000] recv(5, 0x93c4180, 4096, 0) = -1 EAGAIN (Resource temporarily unavailable)
[pid 4000] poll([{fd=6, events=POLLIN}, {fd=5, events=POLLIN}, {fd=7, events=POLLIN}, {fd=10, events=POLLIN}, {fd=9, events=POLLIN}], 5, -1) = 1 ([{fd=5, revents=POLLIN}])
[pid 4000] read(6, 0xbfeb0c0c, 16) = -1 EAGAIN (Resource temporarily unavailable)
[pid 4000] recv(5, "\241 \351\23\6\0\0\4>\1\0\0K\1\0\0\367\2\0\0\6\0\0\4\0\0\0\0\0\0\0\0", 4096, 0) = 32
[pid 4000] recv(5, 0x93c4180, 4096, 0) = -1 EAGAIN (Resource temporarily unavailable)
[pid 4000] poll([{fd=5, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=5, revents=POLLOUT}])
[pid 4000] writev(5, [{"\31\0\v\0]\1\0\0\0\0\30\0! \0\0]\1\0\0>\1\0\0K\1\0\0\367\2\0\0\6\0\0\4\0\0\0\0\0\0\0\0", 44}, {NULL, 0}, {"", 0}], 3) = 44
[pid 4000] recv(5, 0x93c4180, 4096, 0) = -1 EAGAIN (Resource temporarily unavailable)
[pid 4000] recv(5, 0x93c4180, 4096, 0) = -1 EAGAIN (Resource temporarily unavailable)
[pid 4000] poll([{fd=6, events=POLLIN}, {fd=5, events=POLLIN}, {fd=7, events=POLLIN}, {fd=10, events=POLLIN}, {fd=9, events=POLLIN}], 5, -1^C <unfinished ...>

Related branches

Martin Packman (gz) on 2012-03-08
affects: bzr → bzr-gtk
Changed in bzr-gtk:
importance: Undecided → High
status: New → Confirmed
Curtis Hovey (sinzui) wrote :

The progressbar was integrated into the push window and that can be closed.

Changed in bzr-gtk:
status: Confirmed → Fix Committed
assignee: nobody → Curtis Hovey (sinzui)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bzr-gtk (Ubuntu):
status: New → Confirmed
Dražen Lučanin (kermit666) wrote :

Hm, I installed the latest development version of bzr-gtk as Martin Packman (gz) suggested and now the nottification window actually shows an orange progress line, but it's still not integrated with the main command window.

Maybe it's because I haven't updated bzr-explorer itself (was reluctant to do that because the Launchpad page says I would also have to update bzr to 2.6 and this is my production machine so I'm not too keen on running all development versions).

stayros (lsuzex3) on 2015-12-27
Changed in bzr-gtk:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers