bzr crashed with TypeError in __new__(): object of type 'NoneType' has no len()

Bug #914363 reported by Ted Gould on 2012-01-10
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Bazaar GTK+ Frontends
High
Curtis Hovey
bzr-gtk (Ubuntu)
High
Jelmer Vernooij

Bug Description

Using bzr visualize and clicking on a revision.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: bzr 2.5.0~beta4-1ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-8.14-generic 3.2.0
Uname: Linux 3.2.0-8-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
CrashCounter: 1
Date: Tue Jan 10 17:47:36 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/bzr
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/bzr visualize
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
PythonArgs: ['/usr/bin/bzr', 'visualize']
SourcePackage: bzr
Title: bzr crashed with TypeError in __new__(): object of type 'NoneType' has no len()
UpgradeStatus: Upgraded to precise on 2012-01-10 (0 days ago)
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse libvirtd lpadmin netdev plugdev sambashare tape video

Related branches

Ted Gould (ted) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bzr (Ubuntu):
status: New → Confirmed
Jelmer Vernooij (jelmer) on 2012-01-23
visibility: private → public
Curtis Hovey (sinzui) on 2012-01-23
Changed in bzr (Ubuntu):
assignee: nobody → Curtis Hovey (sinzui)
assignee: Curtis Hovey (sinzui) → nobody
assignee: nobody → Curtis Hovey (sinzui)
affects: bzr (Ubuntu) → bzr-gtk (Ubuntu)
Changed in bzr-gtk (Ubuntu):
assignee: Curtis Hovey (sinzui) → nobody
Changed in bzr-gtk:
assignee: nobody → Curtis Hovey (sinzui)
Curtis Hovey (sinzui) on 2012-01-23
Changed in bzr-gtk:
status: New → In Progress
milestone: none → 0.104.0
Curtis Hovey (sinzui) on 2012-01-30
Changed in bzr-gtk:
status: In Progress → Fix Committed
Jelmer Vernooij (jelmer) on 2012-02-14
Changed in bzr-gtk:
importance: Undecided → High
Jelmer Vernooij (jelmer) on 2012-02-14
Changed in bzr-gtk (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High
assignee: nobody → Jelmer Vernooij (jelmer)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr-gtk - 0.103.0+bzr780-1

---------------
bzr-gtk (0.103.0+bzr780-1) unstable; urgency=low

  * Use machine-parseable copyright file format.
  * Bump standards version to 3.9.3 (no changes).
  * Drop suggests of bzr-avahi, which is no longer available. LP:
    #926470
  * New upstream snapshot.
   + Fixes mixed use of gtk2 and gtk3 in bzr-notify. LP: #903444
   + Prevents crash when the diff widget is being closed. LP: #914363
   + Fixes syntax highlighting using the gedit color scheme. LP: #672158
   + Fixes import/type errors in bzr-handle-patch. LP: #926315

 -- Jelmer Vernooij <email address hidden> Wed, 29 Feb 2012 15:04:43 +0100

Changed in bzr-gtk (Ubuntu):
status: In Progress → Fix Released
Jelmer Vernooij (jelmer) on 2012-04-10
Changed in bzr-gtk:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers