per-file commit messages not shown

Bug #904041 reported by Jelmer Vernooij on 2011-12-14
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Bazaar GTK+ Frontends
High
Curtis Hovey

Bug Description

When I do bzr gcommit, a window is shown in which I can enter the per file commit messages. But this per file commit window is too small. And I am unable to make it big (and usable). My environment is given below:

$ bzr version
Bazaar (bzr) 2.4.1
  Python interpreter: /usr/bin/python 2.7.2
  Python standard library: /usr/lib/python2.7
  Platform: Linux-3.0.0-13-generic-x86_64-with-Ubuntu-11.10-oneiric
  bzrlib: /usr/lib/python2.7/dist-packages/bzrlib
  Bazaar configuration: /home/anna/.bazaar
  Bazaar log file: /home/anna/.bzr.log

Copyright 2005-2011 Canonical Ltd.
http://bazaar.canonical.com/

bzr comes with ABSOLUTELY NO WARRANTY. bzr is free software, and
you may use, modify and redistribute it under the terms of the GNU
General Public License version 2 or later.

Bazaar is part of the GNU Project to produce a free operating system.

$

Related branches

mrainb0w (annamalai-gurusami) wrote :

The problem is easily reproduced in Ubuntu 11.10, but does not seem to occur in Ubuntu 11.04. I have attached the screenshot for your reference. Any work around also would be highly appreciated.

Jelmer Vernooij (jelmer) wrote :

What is the version of bzr-gtk you have installed? "bzr plugins -v" should tell you.

Changed in bzr-gtk:
status: New → Triaged
importance: Undecided → High
summary: - gcommit window size is too small
+ per-file commit messages not shown
mrainb0w (annamalai-gurusami) wrote :

I have many plugins installed (about 20 I think). The gtk plugin version as given by "bzr plugins -v" is:

gtk 0.101.0dev
  Graphical support for Bazaar using GTK.
   /usr/lib/python2.7/dist-packages/bzrlib/plugins/gtk

Am 29/12/11 04:13, schrieb Annamalai Gurusami:
> I have many plugins installed (about 20 I think). The gtk plugin
> version as given by "bzr plugins -v" is:
>
> gtk 0.101.0dev
> Graphical support for Bazaar using GTK.
> /usr/lib/python2.7/dist-packages/bzrlib/plugins/gtk
That looks like a development snapshot. Are you running from lp:bzr-gtk ?

Cheers,

Jelmer

Jelmer Vernooij (jelmer) wrote :

Am 29/12/11 04:13, schrieb Annamalai Gurusami:
> I have many plugins installed (about 20 I think). The gtk plugin
> version as given by "bzr plugins -v" is:
>
> gtk 0.101.0dev
> Graphical support for Bazaar using GTK.
> /usr/lib/python2.7/dist-packages/bzrlib/plugins/gtk
That looks like a development snapshot. Are you running from lp:bzr-gtk
perhaps?

Cheers,

Jelmer

mrainb0w (annamalai-gurusami) wrote :

I installed bzr-gtk by doing "sudo apt-get install bzr-gtk". Is that what you are asking? When I issue the command again, I get the following output:

$ sudo apt-get install bzr-gtk
Reading package lists... Done
Building dependency tree
Reading state information... Done
bzr-gtk is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
$
$ bzr plugins | grep gtk
gtk 0.101.0dev
$

Curtis Hovey (sinzui) on 2012-03-22
Changed in bzr-gtk:
assignee: nobody → Curtis Hovey (sinzui)
status: Triaged → In Progress
Curtis Hovey (sinzui) wrote :

I have a branch that requests that the per file message fit at least 2 lines of text

Changed in bzr-gtk:
milestone: none → 0.104.0
Curtis Hovey (sinzui) on 2012-03-22
Changed in bzr-gtk:
status: In Progress → Fix Committed
Jelmer Vernooij (jelmer) on 2012-04-10
Changed in bzr-gtk:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions