bzr-notify crashed with SIGSEGV in g_type_get_qdata()

Bug #903444 reported by Moisa Doru on 2011-12-12
318
This bug affects 52 people
Affects Status Importance Assigned to Milestone
Bazaar GTK+ Frontends
High
Curtis Hovey
bzr-gtk (Ubuntu)
High
Jelmer Vernooij

Bug Description

Updated and removed deprecated packages, removed orphaned packages with deborphan, then restarted.

doru@doru-laptop:~$ lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

doru@doru-laptop:~$ apt-cache policy bzr-gtk
bzr-gtk:
  Installed: 0.100.0+bzr763-1
  Candidate: 0.100.0+bzr763-1
  Version table:
 *** 0.100.0+bzr763-1 0
        500 http://ftp.roedu.net/mirrors/ubuntulinux.org/ubuntu/ precise/universe amd64 Packages
        100 /var/lib/dpkg/statu

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: bzr-gtk 0.100.0+bzr763-1
ProcVersionSignature: Ubuntu 3.2.0-4.10-generic 3.2.0-rc5
Uname: Linux 3.2.0-4-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.90-0ubuntu1
Architecture: amd64
CrashCounter: 1
Date: Tue Dec 13 00:20:38 2011
ExecutablePath: /usr/bin/bzr-notify
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110705.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/bzr-notify
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f837071bd2a <_IO_default_xsputn+10>: push %r13
 PC (0x7f837071bd2a) ok
 source "%r13" ok
 destination "(%rsp)" (0x7fff583b7000) not located in a known VMA region (needed writable region)!
 Stack memory exhausted (SP below stack segment)
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: bzr-gtk
StacktraceTop:
 g_type_get_qdata () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/python2.7/dist-packages/gobject/_gobject.so
 ?? () from /usr/lib/python2.7/dist-packages/gobject/_gobject.so
 ?? () from /usr/lib/python2.7/dist-packages/gobject/_gobject.so
 ?? () from /usr/lib/python2.7/dist-packages/gobject/_gobject.so
Title: bzr-notify crashed with SIGSEGV in g_type_get_qdata()
UpgradeStatus: Upgraded to precise on 2011-12-11 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Moisa Doru (moisadoru) wrote :
visibility: private → public

StacktraceTop:
 g_type_get_qdata (type=<optimized out>, quark=55) at /build/buildd/glib2.0-2.31.2/./gobject/gtype.c:3681
 pygobject_lookup_class (gtype=0) at /build/buildd/pygobject-2-2.28.6/gobject/pygobject.c:905
 pygobject_lookup_class (gtype=0) at /build/buildd/pygobject-2-2.28.6/gobject/pygobject.c:894
 pyg_type_get_bases (gtype=0) at /build/buildd/pygobject-2-2.28.6/gobject/pygobject.c:659
 pygobject_new_with_interfaces (gtype=0) at /build/buildd/pygobject-2-2.28.6/gobject/pygobject.c:702

Changed in bzr-gtk (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bzr-gtk (Ubuntu):
status: New → Confirmed
Curtis Hovey (sinzui) wrote :

bzr-notify is import gobject instead of GObject.

Changed in bzr-gtk (Ubuntu):
assignee: nobody → Curtis Hovey (sinzui)
assignee: Curtis Hovey (sinzui) → nobody
assignee: nobody → Curtis Hovey (sinzui)
assignee: Curtis Hovey (sinzui) → nobody
Changed in bzr-gtk:
status: New → In Progress
assignee: nobody → Curtis Hovey (sinzui)
importance: Undecided → High
tags: added: gtk3
Curtis Hovey (sinzui) on 2012-02-03
Changed in bzr-gtk:
milestone: none → 0.104.0
Curtis Hovey (sinzui) wrote :

I see that bzr-notify is importing pynotify and appidicator, which are gtk2 libs. The fix is not difficult, but the packaging deps will change.

Curtis Hovey (sinzui) on 2012-02-04
Changed in bzr-gtk:
status: In Progress → Fix Committed
tags: added: bugpattern-needed
Jelmer Vernooij (jelmer) on 2012-02-14
Changed in bzr-gtk (Ubuntu):
assignee: nobody → Jelmer Vernooij (jelmer)
importance: Medium → High
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr-gtk - 0.103.0+bzr780-1

---------------
bzr-gtk (0.103.0+bzr780-1) unstable; urgency=low

  * Use machine-parseable copyright file format.
  * Bump standards version to 3.9.3 (no changes).
  * Drop suggests of bzr-avahi, which is no longer available. LP:
    #926470
  * New upstream snapshot.
   + Fixes mixed use of gtk2 and gtk3 in bzr-notify. LP: #903444
   + Prevents crash when the diff widget is being closed. LP: #914363
   + Fixes syntax highlighting using the gedit color scheme. LP: #672158
   + Fixes import/type errors in bzr-handle-patch. LP: #926315

 -- Jelmer Vernooij <email address hidden> Wed, 29 Feb 2012 15:04:43 +0100

Changed in bzr-gtk (Ubuntu):
status: In Progress → Fix Released
Jelmer Vernooij (jelmer) on 2012-04-10
Changed in bzr-gtk:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers