Branch graph becomes too wide

Bug #82907 reported by Jelmer Vernooij on 2007-02-02
8
Affects Status Importance Assigned to Milestone
Bazaar GTK+ Frontends
Undecided
Gary van der Merwe

Bug Description

  affects /products/bzr-gtk
  status confirmed

The branch graph that is shown on the left side in "bzr viz" can become
very wide, pushing the other data out of the visible data of the screen.
I'm not sure how to fix it, but I'd be nice to find some solution to it.
--
Jelmer Vernooij <email address hidden> - http://samba.org/~jelmer/

Daniel Schierbeck (dasch) wrote :

How about putting the commit description below the commiter and date?

  ( ) John Doe <email address hidden> on June 1 2007 14:31
  ||\\ Merges some changes.
  ||( ) Jane Doe <email address hidden> on June 1 2007 09:13
  || || Fixed me some bugs.

Changed in bzr-gtk:
assignee: nobody → garyvdm
status: Confirmed → Fix Committed
T.Gerigk (tgerigk) wrote :

since revno 289 of bzr-gtk
 (http://bazaar.launchpad.net/~bzr/bzr-gtk/trunk/)
the graph is much wider than before.

Attached Patch solves problem for me;
but i think those " / 2 " i added should really be some
auto"magic" scaling factor with "/2" being minimum and "/1" maximum.

Szilveszter Farkas (phanatic) wrote :

bzr-gtk 0.92.0 released.

Changed in bzr-gtk:
milestone: none → 0.92.0
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers