viz slow when run from olive

Bug #70463 reported by Jelmer Vernooij on 2006-11-05
2
Affects Status Importance Assigned to Milestone
Bazaar GTK+ Frontends
Medium
Gary van der Merwe

Bug Description

Olive is slow when used in bound branch. For example the visualisation windows takes a significant amount of time when used in a bound branch - after unbinding, it is much faster.

This problem isn't encountered when running 'bzr viz'.

Jelmer Vernooij (jelmer) on 2006-11-05
Changed in bzr-gtk:
importance: Undecided → Medium
Szilveszter Farkas (phanatic) wrote :

I had quite the same experience with bigger local branches, too. For example bzr.dev Log under Olive takes ages to load (sometimes it doesn't even load), but using 'bzr viz', it's all fine.

  status confirmed
--
Jelmer Vernooij <email address hidden> - http://samba.org/~jelmer/

Changed in bzr-gtk:
status: Unconfirmed → Confirmed

When bzr viz is run, branch.lock_read is called when the window is
opened, and unlock called when it is closed. This is not the case for
when it is opened from olive, and is the reason it is slower. The
attached patch fixes this.

Gary

Gary van der Merwe (garyvdm) wrote :

Note I have change the summary of this bug to specify the viz case. If there are other cases, lets log them as other bugs.

Changed in bzr-gtk:
assignee: nobody → garyvdm
status: Confirmed → In Progress
Szilveszter Farkas (phanatic) wrote :

bzr-gtk 0.92.0 released.

Changed in bzr-gtk:
milestone: 0.16 → 0.92.0
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers