bzr crashed with TypeError in apply_gedit_colors()

Bug #672158 reported by Chris Wilson on 2010-11-07
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar GTK+ Frontends
Medium
Curtis Hovey
bzr-gtk (Ubuntu)
Medium
Jelmer Vernooij

Bug Description

Binary package hint: bzr

I was attempting to diff two versions of a file when the crash occurred. It should be noted that I am using a custom colour scheme in Gedit.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: bzr 2.2.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-22.35-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
Date: Sun Nov 7 14:27:27 2010
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/bzr
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
InterpreterPath: /usr/bin/python2.6
ProcCmdline: /usr/bin/python /usr/bin/bzr visualise
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/bzr', 'visualise']
SourcePackage: bzr
Title: bzr crashed with TypeError in apply_gedit_colors()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

visibility: private → public
tags: removed: need-duplicate-check

I should also point out that Gedit was open at the time.

Jelmer Vernooij (jelmer) on 2011-01-20
affects: bzr (Ubuntu) → bzr-gtk (Ubuntu)
Changed in bzr-gtk (Ubuntu):
status: New → Confirmed
Curtis Hovey (sinzui) on 2012-02-04
Changed in bzr-gtk:
assignee: nobody → Curtis Hovey (sinzui)
importance: Undecided → Medium
status: New → In Progress
Curtis Hovey (sinzui) wrote :

I see a few issues in the problem method and the calling method.
1. The code is checking gconf, but gedit 3's keys are located in dconf
2. The method is attempting to get style information from gedit
3. but language and style was moved to GtkSourceView2 a few years ago
4. bzr-gtk is using GtkSourceView3 which just works.

We can delete several lines of code since it is unneeded.

Curtis Hovey (sinzui) on 2012-02-06
Changed in bzr-gtk:
status: In Progress → Fix Committed
milestone: none → 0.104.0
Jelmer Vernooij (jelmer) on 2012-02-14
Changed in bzr-gtk (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
assignee: nobody → Jelmer Vernooij (jelmer)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr-gtk - 0.103.0+bzr780-1

---------------
bzr-gtk (0.103.0+bzr780-1) unstable; urgency=low

  * Use machine-parseable copyright file format.
  * Bump standards version to 3.9.3 (no changes).
  * Drop suggests of bzr-avahi, which is no longer available. LP:
    #926470
  * New upstream snapshot.
   + Fixes mixed use of gtk2 and gtk3 in bzr-notify. LP: #903444
   + Prevents crash when the diff widget is being closed. LP: #914363
   + Fixes syntax highlighting using the gedit color scheme. LP: #672158
   + Fixes import/type errors in bzr-handle-patch. LP: #926315

 -- Jelmer Vernooij <email address hidden> Wed, 29 Feb 2012 15:04:43 +0100

Changed in bzr-gtk (Ubuntu):
status: In Progress → Fix Released
Jelmer Vernooij (jelmer) on 2012-04-10
Changed in bzr-gtk:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers