0.96.0, 0.99.0 tarball does not contain credits.pickle

Bug #397526 reported by Mark Lee on 2009-07-09
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Bazaar GTK+ Frontends
Jelmer Vernooij
Gentoo Linux
Fix Released

Bug Description

I'm packaging bzr-gtk-0.96.0 for the Bazaar Gentoo overlay, and during install, it errors out with the following:

error: can't copy 'credits.pickle': doesn't exist or not a regular file

A grep of the list of files in bzr-gtk-0.96.0.tar.gz confirms that credits.pickle does not exist in the tarball. I'd like to avoid calling the build_credits command of setup.py, as not only would it need network access to create the pickle, but it would also add a build-time only dependency on bzr-stats.

Related branches

Rejected for merging into lp:bzr-gtk/gtk2
Bazaar GTK maintainers: Pending requested 2011-02-13
Vincent Ladeuil (vila) wrote :

Right, forgive the first-time release-manager, 0.96.1 is on its way, http://bazaar-vcs.org/bzr-gtk/releasing has been corrected accordingly.

Changed in bzr-gtk:
assignee: nobody → Vincent Ladeuil (vila)
importance: Undecided → Critical
status: New → In Progress
Vincent Ladeuil (vila) on 2009-07-09
Changed in bzr-gtk:
milestone: none → 0.96.1
status: In Progress → Fix Released
Vincent Ladeuil (vila) wrote :

People who downloaded http://edge.launchpad.net/bzr-gtk/trunk/0.96.0/+download/bzr-gtk-0.96.0.tar.gz
can still safely use it as long as they don't want to package it themselves.
Since there has been only 3 downloads so far, you know who you are :)

Christian Faulhammer (fauli) wrote :

The problem reappeared for the 0.99.0 release...I want to package for the official Gentoo tree.

Changed in bzr-gtk:
status: Fix Released → Incomplete
Rainer Müller (raimue) wrote :

I am also having the same problem again with 0.99.0 while packaging for MacPorts.

Christian Faulhammer (fauli) wrote :

Can we have a regenerated tarball please?

C-S (c-s) wrote :

I solved this problem by patching it away in my FreeBSD port (http://www.freshports.org/devel/bzr-gtk/). Have a look:


I know that this is a bad solution but it's the best I could do...

Changed in bzr-gtk:
status: Incomplete → Confirmed
Christian Faulhammer (fauli) wrote :

I am reluctant to patch out a credits file...unfortunately this prevents entry of Bazaar 2.2.0 in the testing section of Portage tree in Gentoo.

Changed in gentoo:
status: Unknown → Confirmed
C-S (c-s) wrote :

I totally agree with Christian. I am not happy at all, especially because everybody here knows that this bug is not really a big deal. One step in the release process was forgotten, that's all. Hence, please just re-release bzr-gtk as 0.9.1....

C-S (c-s) wrote :

By the way. My reason for doing the patch was that bzr 2.2.0 was already published in the ports system. Hence not porting bzr-gtk 0.9.0 would have left many users unhappy, as the old bzr-gtk 0.8.7 is not compatible with bzr 2.2.0.

Changed in gentoo:
status: Confirmed → Fix Released
Max Bowsher (maxb) on 2010-09-02
Changed in bzr-gtk:
assignee: Vincent Ladeuil (vila) → nobody
milestone: 0.96.1 → none
summary: - 0.96.0 tarball does not contain credits.pickle
+ 0.96.0, 0.99.0 tarball does not contain credits.pickle
Changed in gentoo:
importance: Unknown → Wishlist
Jelmer Vernooij (jelmer) on 2011-02-17
Changed in bzr-gtk:
assignee: nobody → Jelmer Vernooij (jelmer)
Jelmer Vernooij (jelmer) on 2011-03-02
Changed in bzr-gtk:
status: Confirmed → Fix Released
Rainer Müller (raimue) wrote :

The problem reappeared once again for bzr-gtk 0.104.0. My new bug report #1032995 has been marked as a duplicate of this one here, so please reopen.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.