GTK+ Frontends to Various Bazaar Commands

Activity log for bug #377476

Date Who What changed Old value New value Message
2009-05-17 02:45:35 Andrew Cowie bug added bug
2009-05-17 03:13:14 Jelmer Vernooij affects bzr bzr-gtk
2009-05-26 08:18:27 Szilveszter Farkas branch linked lp:~phanatic/bzr-gtk/bug377476
2009-05-27 10:18:44 Jelmer Vernooij bzr-gtk: importance Undecided High
2009-05-27 10:18:44 Jelmer Vernooij bzr-gtk: status New Triaged
2009-06-09 13:49:41 Michael Terry bug watch added https://bugzilla.redhat.com/show_bug.cgi?id=498138
2009-06-09 13:49:41 Michael Terry bug task added bzr-gtk (Fedora)
2009-06-09 13:50:03 Michael Terry bug task added bzr-gtk (Ubuntu)
2009-06-09 13:50:28 Michael Terry bzr-gtk (Ubuntu): status New Confirmed
2009-06-09 14:03:11 Bug Watch Updater bzr-gtk (Fedora): status Unknown Confirmed
2009-06-09 14:12:12 Michael Terry bug watch added http://bugzilla.gnome.org/show_bug.cgi?id=585255
2009-06-09 14:12:12 Michael Terry bug task added seahorse
2009-06-09 14:21:40 Bug Watch Updater seahorse: status Unknown New
2009-06-09 19:38:18 Michael Terry bug watch added http://bugzilla.gnome.org/show_bug.cgi?id=583356
2009-06-09 19:38:18 Michael Terry seahorse: status New Unknown
2009-06-09 19:38:18 Michael Terry seahorse: remote watch GNOME Bug Tracker #585255 GNOME Bug Tracker #583356
2009-06-09 19:41:38 Bug Watch Updater seahorse: status Unknown Fix Released
2009-06-10 05:35:07 Launchpad Janitor bzr-gtk (Ubuntu): status Confirmed Fix Released
2009-07-03 12:23:33 Jelmer Vernooij bzr-gtk: status Triaged Invalid
2009-07-03 12:23:46 Jelmer Vernooij affects bzr-gtk (Ubuntu) seahorse (Ubuntu)
2009-07-06 07:12:22 Martin Pool description Strangely, it was just this branch that failed; bzr viz works in my mainline. AfC moonglow ~/vcs/java-gnome/vreixo-old-changes $ bzr viz /home/andrew/.bazaar/plugins/gtk/ui.py:224: DeprecationWarning: bzrlib.progress.ProgressBarStack was deprecated in version 1.12. self._progress_bar_stack = progress.ProgressBarStack(klass=widget) bzr: ERROR: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 0 Traceback (most recent call last): File "/usr/lib/python2.6/site-packages/bzrlib/commands.py", line 727, in exception_to_return_code return the_callable(*args, **kwargs) File "/usr/lib/python2.6/site-packages/bzrlib/commands.py", line 922, in run_bzr ret = run(*run_argv) File "/usr/lib/python2.6/site-packages/bzrlib/commands.py", line 559, in run_argv_aliases return self.run(**all_cmd_args) File "/home/andrew/.bazaar/plugins/gtk/commands.py", line 189, in run pp = start_viz_window(br, revids, limit) File "/home/andrew/.bazaar/plugins/gtk/commands.py", line 157, in start_viz_window from bzrlib.plugins.gtk.viz import BranchWindow File "/home/andrew/.bazaar/plugins/gtk/viz/__init__.py", line 14, in <module> from branchwin import BranchWindow File "/home/andrew/.bazaar/plugins/gtk/viz/branchwin.py", line 18, in <module> from bzrlib.plugins.gtk.tags import AddTagDialog File "/home/andrew/.bazaar/plugins/gtk/tags.py", line 27, in <module> from bzrlib.plugins.gtk.revisionview import RevisionView File "/home/andrew/.bazaar/plugins/gtk/revisionview.py", line 33, in <module> from bzrlib.plugins.gtk import seahorse File "/home/andrew/.bazaar/plugins/gtk/seahorse.py", line 33, in <module> crypto = dbus.Interface(bus.get_object(BUS_NAME, CRYPTO_PATH), File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 244, in get_object follow_name_owner_changes=follow_name_owner_changes) File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 241, in __init__ self._named_service = conn.activate_name_owner(bus_name) File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 183, in activate_name_owner self.start_service_by_name(bus_name) File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 281, in start_service_by_name 'su', (bus_name, flags))) File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 622, in call_blocking message, timeout) DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 0 bzr 1.14.1 on python 2.6.2 (linux2) arguments: ['/usr/bin/bzr', 'viz'] encoding: 'UTF-8', fsenc: 'UTF-8', lang: 'en_CA.UTF-8' plugins: gtk /home/andrew/.bazaar/plugins/gtk [0.96.0.dev.1] launchpad /usr/lib/python2.6/site-packages/bzrlib/plugins/launchpad [unknown] netrc_credential_store /usr/lib/python2.6/site-packages/bzrlib/plugins/netrc_credential_store [unknown] push_and_update /home/andrew/.bazaar/plugins/push_and_update [0.2dev] Various bzr-gtk commands can fail to start because of a dbus error. Repeating the command will typically fix the problem. mbp@grace% ./bzr selftest TestReconfigureStacking bzr: ERROR: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 0 Traceback (most recent call last): File "/home/mbp/bzr/391411-reconfigure-stacked/bzrlib/commands.py", line 835, in exception_to_return_code return the_callable(*args, **kwargs) File "/home/mbp/bzr/391411-reconfigure-stacked/bzrlib/commands.py", line 1030, in run_bzr ret = run(*run_argv) File "/home/mbp/bzr/391411-reconfigure-stacked/bzrlib/commands.py", line 647, in run_argv_aliases return self.run(**all_cmd_args) File "/home/mbp/bzr/391411-reconfigure-stacked/bzrlib/builtins.py", line 3474, in run result = selftest(**selftest_kwargs) File "/home/mbp/bzr/391411-reconfigure-stacked/bzrlib/tests/__init__.py", line 3146, in selftest suite = test_suite(keep_only, starting_with) File "/home/mbp/bzr/391411-reconfigure-stacked/bzrlib/tests/__init__.py", line 3586, in test_suite plugin_suite = plugin.load_plugin_tests(loader) File "/home/mbp/bzr/391411-reconfigure-stacked/bzrlib/plugin.py", line 383, in load_plugin_tests return loader.loadTestsFromModule(self.module) File "/home/mbp/bzr/391411-reconfigure-stacked/bzrlib/tests/TestUtil.py", line 129, in loadTestsFromModule return load_tests(basic_tests, module, self) File "/home/mbp/.bazaar/plugins/gtk/__init__.py", line 190, in load_tests ["%s.%s" % (__name__, tmn) for tmn in testmod_names])) File "/home/mbp/bzr/391411-reconfigure-stacked/bzrlib/tests/TestUtil.py", line 92, in loadTestsFromModuleNames result.addTests(self.loadTestsFromModuleName(name)) File "/home/mbp/bzr/391411-reconfigure-stacked/bzrlib/tests/TestUtil.py", line 99, in loadTestsFromModuleName result.addTests(self.loadTestsFromModule(module)) File "/home/mbp/bzr/391411-reconfigure-stacked/bzrlib/tests/TestUtil.py", line 129, in loadTestsFromModule return load_tests(basic_tests, module, self) File "/home/mbp/.bazaar/plugins/gtk/tests/__init__.py", line 31, in load_tests ["%s.%s" % (__name__, tmn) for tmn in testmod_names])) File "/home/mbp/bzr/391411-reconfigure-stacked/bzrlib/tests/TestUtil.py", line 92, in loadTestsFromModuleNames result.addTests(self.loadTestsFromModuleName(name)) File "/home/mbp/bzr/391411-reconfigure-stacked/bzrlib/tests/TestUtil.py", line 97, in loadTestsFromModuleName module = _load_module_by_name(name) File "/home/mbp/bzr/391411-reconfigure-stacked/bzrlib/tests/TestUtil.py", line 166, in _load_module_by_name module = __import__(mod_name) File "/home/mbp/.bazaar/plugins/gtk/tests/test_annotate_config.py", line 23, in <module> from bzrlib.plugins.gtk.annotate import ( File "/home/mbp/.bazaar/plugins/gtk/annotate/gannotate.py", line 31, in <module> from bzrlib.plugins.gtk.revisionview import RevisionView File "/home/mbp/.bazaar/plugins/gtk/revisionview.py", line 36, in <module> from bzrlib.plugins.gtk import seahorse File "/home/mbp/.bazaar/plugins/gtk/seahorse.py", line 33, in <module> crypto = dbus.Interface(bus.get_object(BUS_NAME, CRYPTO_PATH), File "/var/lib/python-support/python2.6/dbus/bus.py", line 244, in get_object follow_name_owner_changes=follow_name_owner_changes) File "/var/lib/python-support/python2.6/dbus/proxies.py", line 241, in __init__ self._named_service = conn.activate_name_owner(bus_name) File "/var/lib/python-support/python2.6/dbus/bus.py", line 183, in activate_name_owner self.start_service_by_name(bus_name) File "/var/lib/python-support/python2.6/dbus/bus.py", line 281, in start_service_by_name 'su', (bus_name, flags))) File "/var/lib/python-support/python2.6/dbus/connection.py", line 622, in call_blocking message, timeout) DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 0
2009-10-08 03:40:17 Stephen Warren seahorse (Ubuntu): status Fix Released Confirmed
2009-10-08 08:27:53 Sebastien Bacher seahorse (Ubuntu): status Confirmed Fix Released
2009-11-12 10:51:43 Bug Watch Updater bzr-gtk (Fedora): status Confirmed Fix Released
2009-12-05 03:05:31 Launchpad Janitor branch linked lp:ubuntu/bzr-gtk
2010-09-16 11:44:49 Bug Watch Updater seahorse: importance Unknown Medium