gannotate traceback when gannotate.conf does not exist

Bug #373157 reported by Vincent Ladeuil
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar GTK+ Frontends
Critical
Vincent Ladeuil

Bug Description

This occurs when gannotate.conf does not exist and using bzr.dev with revno >= 4314, i.e. upgrading configobj to 4.6.0 breaks an assumption made by GAnnotateConfig.

This a new bug revealed by the recent upgrade, but the root cause is in fact an older one (very very old).

More precisely, GAnnotateConfig has been broken for ages regarding reloading an existing config file (now you know why you always got the same window at the same size at the same place even when this options are supposed to restored from the config file).

I'm working on a patch.

Marking as critical as any *new* user will encounter the problem.

Related branches

Vincent Ladeuil (vila)
Changed in bzr-gtk:
milestone: none → 0.96.0
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers