olive-gtk crashed with AttributeError in set_revision()

Bug #281717 reported by Lars Kumbier on 2008-10-11
32
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Bazaar GTK+ Frontends
Medium
Jelmer Vernooij
bzr-gtk (Ubuntu)
Medium
Jelmer Vernooij

Bug Description

Binary package hint: bzr-gtk

// desc
Olive (bzr-gtk) crashed while showing the log of a fresh initiated project

// OS
Ubuntu 8.10 Intrepid (amd64)

// Package
bzr-gtk 0.95.0-1ubuntu4

// Reproducerate: 100%
(1) open terminal and perform the following commands
# mkdir myProject
# cd myProject
# mkdir sub1
# touch test1.c test2.c test3.txt sub1/test4.c
# bzr init
(2) open olive
(3) open myProject-directory
(4) choose "statistics -> log"
Last step will show the logwindow and result in a crash of bzr-gtk after a few seconds.

ProblemType: Crash
Architecture: amd64
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/bin/olive-gtk
InterpreterPath: /usr/bin/python2.5
NonfreeKernelModules: nvidia
Package: bzr-gtk 0.95.0-1ubuntu4
PackageArchitecture: all
ProcAttrCurrent: unconfined
ProcCmdline: /usr/bin/python /usr/bin/olive-gtk
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/olive-gtk']
SourcePackage: bzr-gtk
Title: olive-gtk crashed with AttributeError in set_revision()
Uname: Linux 2.6.27-7-generic x86_64
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev sambashare users vboxusers video

Lars Kumbier (derlars) wrote :
C de-Avillez (hggdh2) on 2010-01-12
visibility: private → public
Vish (vish) wrote :

Happens on Lucid as well. The traceback seems to be the same from my bug too.
But i get the crash report often while checking the Branch>Tags dialogue window

Changed in bzr-gtk (Ubuntu):
status: New → Confirmed
Martin Albisetti (beuno) wrote :

I can reproduce this with trunk. This comes up because nothing has been committed yet, so self._revision is None.

Changed in bzr-gtk (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Changed in bzr-gtk:
status: New → Triaged
importance: Undecided → Medium
Vish (vish) wrote :

Also happens when I select the Branch > Tags > Signature tab.

Oddly it happens only for the signature tab and no other tabs in that dialogue

Vish (vish) wrote :

With the signature tab it is irrespective of the commit. It happens even when there are no changes/commits.

Jelmer Vernooij (jelmer) on 2012-03-01
Changed in bzr-gtk:
status: Triaged → Fix Committed
assignee: nobody → Jelmer Vernooij (jelmer)
Jelmer Vernooij (jelmer) on 2012-03-24
Changed in bzr-gtk (Ubuntu):
status: Triaged → Fix Committed
assignee: nobody → Jelmer Vernooij (jelmer)
Changed in bzr-gtk:
milestone: none → 0.104.0
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr-gtk - 0.103.0+bzr792-1ubuntu1

---------------
bzr-gtk (0.103.0+bzr792-1ubuntu1) precise; urgency=low

  * Merge from Debian. Remaining changes:
   + Add build dependency on appmenu-gtk3, required to prevent module
     loading errors in bzr-notify tests.

bzr-gtk (0.103.0+bzr792-1) unstable; urgency=low

  * New upstream snapshot.
   + Prevents bzr-handle-patch from showing up in software center.
     LP: #854245
   + Fixes crash when no revision is available in 'bzr viz'. LP: #281717
   + Fixes searching in 'bzr viz'. LP: #928301

bzr-gtk (0.103.0+bzr780-2) unstable; urgency=low

  * Swap elements of or condition build-dependecy, to make some autobuilders
    happy. Closes: #664958
 -- Jelmer Vernooij <email address hidden> Tue, 03 Apr 2012 02:19:20 +0200

Changed in bzr-gtk (Ubuntu):
status: Fix Committed → Fix Released
Jelmer Vernooij (jelmer) on 2012-04-10
Changed in bzr-gtk:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers