bzr-vimdiff-9999.ebuild uses deprecated function 'python_version' -- fails to install

Bug #783669 reported by dynamotwain
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gentoo Overlay for Bazaar
Undecided
Unassigned

Bug Description

The function 'python_version' and the PYVER variables are banned; this causes the bzr-vimdiff ebuild to fail to install.

The attached patch replaces python_version() / $(PYVER) usage with python_execute_function() / python_get_sitedir() to be multiple-ABI compliant (like the ebuild claims), and also compiles/optimizes the plugin w/ python_mod_optimize.

Related branches

Revision history for this message
dynamotwain (dynamotwain) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers