Gentoo Overlay for Bazaar

Problem during syncing bzr overlay under Gentoo Linux

Reported by Jakub Hudak on 2009-09-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar Subversion Plugin
Undecided
Jelmer Vernooij
Gentoo Overlay for Bazaar
Low
Unassigned

Bug Description

* Running command "cd "/usr/local/portage/layman/bazaar" && /usr/bin/bzr pull --overwrite "lp:bzr-gentoo-overlay""...
No module named send
Unable to load plugin 'svn' from '/usr/lib/python2.6/site-packages/bzrlib/plugins'
/usr/lib/python2.6/site-packages/bzrlib/plugins/svn/format.py:86: RuntimeWarning: Parent module 'bzrlib.plugins.svn' not found while handling absolute import
  from bzrlib.transport.local import LocalTransport
You have not informed bzr of your Launchpad ID, and you must do this to
write to Launchpad or access private data. See "bzr help launchpad-login".
http://bazaar.launchpad.net/%7Emalept/bzr-gentoo-overlay/overlay-main is permanently redirected to /~malept/bzr-gentoo-overlay/overlay-main/changes
You have not informed bzr of your Launchpad ID, and you must do this to
write to Launchpad or access private data. See "bzr help launchpad-login".
/usr/lib/python2.6/site-packages/bzrlib/plugins/svn/format.py:62: RuntimeWarning: Parent module 'bzrlib.plugins.svn' not found while handling absolute import
  from bzrlib.plugins.svn import lazy_check_versions
bzr: ERROR: exceptions.ImportError: cannot import name format

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/bzrlib/commands.py", line 729, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/bzrlib/commands.py", line 924, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib/python2.6/site-packages/bzrlib/commands.py", line 560, in run_argv_aliases
    return self.run(**all_cmd_args)
  File "/usr/lib/python2.6/site-packages/bzrlib/builtins.py", line 943, in run
    possible_transports=possible_transports)
  File "/usr/lib/python2.6/site-packages/bzrlib/branch.py", line 140, in open
    possible_transports=possible_transports)
  File "/usr/lib/python2.6/site-packages/bzrlib/bzrdir.py", line 837, in open
    return BzrDir.open_from_transport(t, _unsupported=_unsupported)
  File "/usr/lib/python2.6/site-packages/bzrlib/bzrdir.py", line 867, in open_from_transport
    redirected)
  File "/usr/lib/python2.6/site-packages/bzrlib/transport/__init__.py", line 1642, in do_catching_redirections
    return action(transport)
  File "/usr/lib/python2.6/site-packages/bzrlib/bzrdir.py", line 854, in find_format
    transport, _server_formats=_server_formats)
  File "/usr/lib/python2.6/site-packages/bzrlib/bzrdir.py", line 1785, in find_format
    return format.probe_transport(transport)
  File "/usr/lib/python2.6/site-packages/bzrlib/plugins/svn/format.py", line 104, in probe_transport
    klass._check_versions()
  File "/usr/lib/python2.6/site-packages/bzrlib/plugins/svn/format.py", line 62, in _check_versions
    from bzrlib.plugins.svn import lazy_check_versions
  File "/usr/lib/python2.6/site-packages/bzrlib/plugins/svn/__init__.py", line 138, in <module>
    from bzrlib.plugins.svn import format
ImportError: cannot import name format

bzr 1.15.1 on python 2.6.2 (linux2)
arguments: ['/usr/bin/bzr', 'pull', '--overwrite', 'lp:bzr-gentoo-overlay']
encoding: 'ANSI_X3.4-1968', fsenc: 'ANSI_X3.4-1968', lang: None
plugins:
  bzrtools /usr/lib/python2.6/site-packages/bzrlib/plugins/bzrtools [1.15]
  git /usr/lib/python2.6/site-packages/bzrlib/plugins/git [0.4.1]
  launchpad /usr/lib/python2.6/site-packages/bzrlib/plugins/launchpad [1.15.1]
  netrc_credential_store /usr/lib/python2.6/site-packages/bzrlib/plugins/netrc_credential_store [1.15.1]
*** Bazaar has encountered an internal error.
    Please report a bug at https://bugs.launchpad.net/bzr/+filebug
    including this traceback, and a description of what you
    were doing when the error occurred.

Vincent Ladeuil (vila) on 2009-09-08
affects: bzr → bzr-gentoo-overlay
Mark Lee (malept) wrote :

Sounds like a bzr-svn problem to me, not a bzr-gentoo-overlay problem. Specifically, it sounds like a broken bzr-svn install.

affects: bzr-gentoo-overlay → bzr-svn
Jelmer Vernooij (jelmer) wrote :

This can occur when your version of bzr-svn is too old.

Changed in bzr-svn:
status: New → Invalid
Jakub Hudak (jakub-cium) wrote :

I fix portage overlay problem, remove bzr-svn, and remove bazaar overlay from layman. And when i run layman -a bazaar got:

layman -a bazaar
* Running command "/usr/bin/bzr get "lp:bzr-gentoo-overlay/" "/usr/local/portage/layman/bazaar""...
invalid syntax (<string>, line 1)
Unable to load '.svn' in '/usr/lib/python2.6/site-packages/bzrlib/plugins' as a plugin because the file path isn't a valid module name; try renaming it to '_svn'.
You have not informed bzr of your Launchpad ID, and you must do this to
write to Launchpad or access private data. See "bzr help launchpad-login".
bzr: ERROR: Target directory "/usr/local/portage/layman/bazaar" already exists.
* Failed to add overlay "bazaar".
* Error was: Adding the overlay failed! Possible remains of the opration have NOT been removed and may be left at /usr/local/portage/layman/bazaar. Please remove them manually if required.

I rename proposed directory (.svn to _svn) and when i run layman -a bazaar got:

layman -a bazaar
* Running command "/usr/bin/bzr get "lp:bzr-gentoo-overlay/" "/usr/local/portage/layman/bazaar""...
No module named svn
Unable to load plugin '_svn' from '/usr/lib/python2.6/site-packages/bzrlib/plugins'
You have not informed bzr of your Launchpad ID, and you must do this to
write to Launchpad or access private data. See "bzr help launchpad-login".
bzr: ERROR: Target directory "/usr/local/portage/layman/bazaar" already exists.
* Failed to add overlay "bazaar".
* Error was: Adding the overlay failed! Possible remains of the opration have NOT been removed and may be left at /usr/local/portage/layman/bazaar. Please remove them manually if required.

Jakub Hudak (jakub-cium) wrote :

Ok, for many bloody battles i fixed the problem. Generally ebuild bzr-svn from gentoo overlay needs ebuilds >=bzr-1.18 and >=bzrtools-1.18.0 which are masked by ~arch keyword. Please fix the bzr-svn ebuild dependencies and set this bug as resolved.

Jakub Hudak (jakub-cium) on 2009-09-09
Changed in bzr-svn:
status: Invalid → Fix Committed
Jelmer Vernooij (jelmer) wrote :

not a bug in upstream bzr-svn

Changed in bzr-svn:
status: Fix Committed → Won't Fix
status: Won't Fix → Invalid
Mark Lee (malept) wrote :

There is no dependency issue here.

According to bzr-svn 0.6.5's info.py, it works with bzr >= 1.15.

Additionally, bzr-svn is also keyworded ~amd64 and ~x86, so there are no "stable arch" vs. "unstable arch" issues.

Changed in bzr-gentoo-overlay:
importance: Undecided → Low
status: New → Invalid
Jakub Hudak (jakub-cium) wrote :

If no dependency issue here, so why i have that problem, and after upgrade theese two ebuilds it works?

Mark Lee (malept) wrote :

I removed my entries for bzr and bzrtools in package.keywords (I left the bzr-svn one in for obvious reasons), and ran emerge:

$ emerge -pv bzr bzrtools bzr-svn

These are the packages that would be merged, in order:

Calculating dependencies ... done!
[ebuild UD] dev-util/bzr-1.15.1 [2.0_rc1] USE="bash-completion curl doc sftp -emacs -test (-kerberos%)" 0 kB [1=>0]
[ebuild UD] dev-util/bzrtools-1.15.0 [2.0.0] 0 kB [1=>0]
[ebuild R ] dev-util/bzr-svn-0.6.5 0 kB [1]

Again, it looks OK to me.

Jakub Hudak (jakub-cium) wrote :

You misunderstood me. To correct work of bzr-svn you need merged bzr-1.18 and bzrtools-1.18.0. You don't downgrade bzr and bzrtools to 1.15 versions and check if bzr-svn works with versions lower than 1.18. You show only dependency tree which is bad, because bzr-svn need higher versions of bzr and bzrtools ebuilds as i wrote earlier.

Mark Lee (malept) wrote :

As I said earlier:

> According to bzr-svn 0.6.5's info.py, it works with bzr >= 1.15.

If this is not the case, then it is a bug in bzr-svn.

On Wed, Sep 09, 2009 at 07:33:51PM -0000, Mark Lee wrote:
> As I said earlier:
> > According to bzr-svn 0.6.5's info.py, it works with bzr >= 1.15.
> If this is not the case, then it is a bug in bzr-svn.

Sorry, I had missed that.

I've removed 1.15 from the list of supported versions.

  affects bzr-svn
  status fixreleased

Cheers,
Jelmer

Changed in bzr-svn:
status: Invalid → Fix Released
Jelmer Vernooij (jelmer) on 2009-09-12
Changed in bzr-svn:
assignee: nobody → Jelmer Vernooij (jelmer)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers