emerge =subversion-1.4.4-r2 fails

Bug #124227 reported by David Owen on 2007-07-05
2
Affects Status Importance Assigned to Milestone
Gentoo Overlay for Bazaar
Undecided
Mark Lee

Bug Description

Using the overlay version Fri 2007-06-22 22:25:04 -0700, emerge =subversion-1.4.4-r2 fails with the following output:

...
 * Applying subversion-1.4.0-metze-python-bindings.patch ... [ ok ]
/usr/portage/local/bazaar-overlay/dev-util/subversion/subversion-1.4.4-r2.ebuild: /usr/portage/local/bazaar-overlay/dev-util/subversion/files/convert-typemaps-to-ifdef.py: /usr/bin/env: bad interpreter: Permission denied

Attempting to execute convert-typemaps-to-ifdef.py directly from the shell yields the same error.

David Owen (dsowen) wrote :

I found the cause: my portage trees are on their own filesystem mounted noexec,nosuid for safety reasons. I've had this config for a long time, and never had a problem with any official ebuilds.

May I request that the ebuilds be modified to work from noexec filesystems? The attached patch seems to work for me.

Mark Lee (malept) wrote :

Thanks for the bug report. Your patch has been applied to both subversion ebuilds and has been committed in revision 36.

Changed in bzr-gentoo-overlay:
assignee: nobody → malept
status: New → Fix Committed
Changed in bzr-gentoo-overlay:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers