unexpected keyword argument 'control'

Bug #736681 reported by Gustavo Niemeyer on 2011-03-17
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Bazaar Fast Import
Critical
Jelmer Vernooij
bzr-fastimport (Ubuntu)
Critical
Jelmer Vernooij

Bug Description

In Ubuntu maverick, I'm getting the following exception with bzr-fastimport + fastimport from trunk:

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/bzrlib/commands.py", line 912, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/bzrlib/commands.py", line 1112, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib/python2.6/dist-packages/bzrlib/commands.py", line 690, in run_argv_aliases
    return self.run(**all_cmd_args)
  File "/usr/lib/python2.6/dist-packages/bzrlib/commands.py", line 705, in run
    return self._operation.run_simple(*args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/bzrlib/cleanup.py", line 135, in run_simple
    self.cleanups, self.func, *args, **kwargs)
  File "/usr/lib/python2.6/dist-packages/bzrlib/cleanup.py", line 165, in _do_with_cleanups
    result = func(*args, **kwargs)
  File "/home/niemeyer/.bazaar/plugins/fastimport/cmds.py", line 313, in run
    params=params, verbose=verbose, user_map=user_map)
  File "/home/niemeyer/.bazaar/plugins/fastimport/cmds.py", line 38, in _run
    proc = processor_factory(verbose=verbose, **kwargs)
TypeError: __init__() got an unexpected keyword argument 'control'

Gustavo Niemeyer (niemeyer) wrote :

Using revision 309 of bzr-fastimport, which used positional arguments in cmds.py, fixed the problem.

Joon Ro (joonpy) wrote :

I actually am having exactly the same problem, even though I downloaded the latest revision (313).
Any suggestions?

Joon Ro (joonpy) wrote :

There must have been some inconsistencies among the versions of bzr utilities I have. I just installed 0.10, and it started working well.

Gustavo Niemeyer (niemeyer) wrote :

Yeah, that's the same reported above. Revision 309 is from 0.10, IIRC.

Chris Hecker (checker-lp) wrote :

Same here just now, brz up -r 309 fixed it.

Gustavo Niemeyer (niemeyer) wrote :

bzr fast import is broken in Natty due to this bug.

Jelmer Vernooij (jelmer) on 2011-04-28
Changed in bzr-fastimport (Ubuntu):
status: New → Triaged
Changed in bzr-fastimport:
status: New → Triaged
importance: Undecided → Critical
Changed in bzr-fastimport (Ubuntu):
importance: Undecided → Critical
Changed in bzr-fastimport:
assignee: nobody → Jelmer Vernooij (jelmer)
Changed in bzr-fastimport (Ubuntu):
assignee: nobody → Jelmer Vernooij (jelmer)
Jelmer Vernooij (jelmer) wrote :

Fixed in r315, with two new blackbox tests to prevent future regressions like this.

Changed in bzr-fastimport:
status: Triaged → Fix Released
Changed in bzr-fastimport (Ubuntu):
status: Triaged → In Progress
Gustavo Niemeyer (niemeyer) wrote :

Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr-fastimport - 0.10.0+bzr317-1

---------------
bzr-fastimport (0.10.0+bzr317-1) unstable; urgency=low

  * New upstream snapshot.
   + Fixes 'bzr fast-import' command. LP: #736681
 -- Ubuntu Archive Auto-Sync <email address hidden> Sat, 30 Apr 2011 12:39:26 +0000

Changed in bzr-fastimport (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers