fast-export --plain emits multiple authors if present in bzr repository

Bug #496677 reported by Arjen Laarhoven on 2009-12-14
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Bazaar Fast Import
Low
Jelmer Vernooij
bzr-fastimport (Ubuntu)
Undecided
Jelmer Vernooij

Bug Description

If a commit in a bzr repository contains multiple authors, they all get emitted despite the default of the '--plain' option.

Johan Kiviniemi (ion) wrote :

Confirming the problem. --plain emits multiple authors and git fast-import crashes.

Changed in bzr-fastimport:
status: New → Confirmed
Changed in bzr-fastimport (Ubuntu):
status: New → Confirmed
David Kilzer (ddkilzer-yahoo) wrote :

See also this thread from the git mailing list:

git fast-import crashes importing commits with more than one author
<http://marc.info/?t=127272865200002&r=1&w=2>

David Futcher (bobbo) on 2010-06-09
tags: added: patch-forwarded-upstream
Stijn Hoop (fritti) wrote :

Either Arjan's patch or the change David Kilzer linked in #3 works for me, but as far as I can see neither is included in the "canonical" bzr fast-export repository. It would be nice to include it, I can confirm it works for me.

David Kilzer (ddkilzer-yahoo) wrote :
Jelmer Vernooij (jelmer) wrote :

Fixed in trunk.

Changed in bzr-fastimport:
status: Confirmed → Fix Committed
importance: Undecided → Low
assignee: nobody → Jelmer Vernooij (jelmer)
Jelmer Vernooij (jelmer) on 2010-12-12
Changed in bzr-fastimport (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Jelmer Vernooij (jelmer)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr-fastimport - 0.9.0+bzr299-1

---------------
bzr-fastimport (0.9.0+bzr299-1) unstable; urgency=low

  * New upstream snapshot.
   + Emits only a single author when --plain is specified. LP: #496677
   + Imports binary_stream from python-fastimport helpers. Closes: #605351
   + Supports newer marks file format. Closes: #523858, LP: #347729
  * New upstream snapshot.
 -- Ubuntu Archive Auto-Sync <email address hidden> Sat, 18 Dec 2010 12:07:05 +0000

Changed in bzr-fastimport (Ubuntu):
status: Fix Committed → Fix Released
Jelmer Vernooij (jelmer) on 2011-03-11
Changed in bzr-fastimport:
status: Fix Committed → Fix Released
milestone: none → 0.10.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers