Checkout dialog should provide lightweight option that is false by default.

Bug #907708 reported by INADA Naoki on 2011-12-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar Explorer
High
Alexander Belchenko

Bug Description

"bzr checkout" makes bound branch with working tree by default but bzr-explorer's checkout dialog
makes lightweight without any description.

lightweight checkout from bzr+ssh may cause DoS Attack to ssh-server.

Related branches

Changed in bzr-explorer:
status: New → Confirmed
importance: Undecided → High
milestone: none → 1.3.0
Alexander Belchenko (bialix) wrote :

Current Explorer version has checkout dialog without checkbox for lightweight.

Alexander Belchenko (bialix) wrote :

OK, the truth is explorer re-uses qgetnew dialog but hides working tree options and forces light-weight checkout. There is comment from Ian:

        # Hide the options group box - checkouts are always lightweight in
        # explorer. If users want a heavyweight checkout, they need to use
        # the Branch dialog and bind the branch instead.

qgetnew is a bit overloaded with options. We have to revert this decision, but hide non-checkout options.

Alexander Belchenko (bialix) wrote :

Here is ugly result I have. I unable to get rid of the extra blank line below light-weight checkout option, because there is spacer item and it's not member of the class.

Alexander Belchenko (bialix) wrote :

Naoki, is it accaptable solution for you?

INADA Naoki (songofacandy) wrote :

Looks good for me. Thank you.

Changed in bzr-explorer:
assignee: nobody → Alexander Belchenko (bialix)
status: Confirmed → Fix Released

Alexander,

do you insist on forcing heavy checkouts in general?
Because I want to make this option configurable in qconfig, on the tab 'User Interface'.

Alexander Belchenko (bialix) wrote :

@André, probably you don't need to add anything to qconfig :-)
I've already added that option to Explorer - Tools - Options - Behavior - Default Values in Dialogs, see screenshot. It's done inside Explorer code and don't affect qbzr itself. I'm not sure whether we need to duplicate that for qbzr itself.

Many thanks, you're the best! ;)

André Bachmann пишет:
> Many thanks, you're the best! ;)
>
Thank you for kind words but actually this feature was implemented
before me and laid here on launchpad in branch of other author
(Martin Guillon)

That's bad I haven't seen his work before, but it's good I found it just
in time for this change :-)

--
All the dude wanted was his rug back

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers