Explorer: Error related to deleting a working tree and changing tabs

Bug #806982 reported by André Bachmann on 2011-07-07
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar Explorer

Bug Description

I'm using Bazaar 2.3.3-3 with qbzr trunk (rev. 1409).

Steps to reproduce this problem:

1) Create a new repository with Bazaar Explorer, this runs the following command:
bzr new --feature-branches --format 2a C:/spielwiese/testen
Created repository at C:/spielwiese/testen
Created branch at C:/spielwiese/testen/trunk
2) Bazaar Explorer then opens a new tab with the repo, after that I also open the branch 'trunk' in a tab.
3) Create a new branch 'test1' from repository tab, open it within a new tab. This is now your active tab.
4) run:
bzr remove-tree c:\spielwiese\testen\trunk
bzr remove-tree c:\spielwiese\testen\test1
5) When going back to Bazaar Explorer and clicking refresh on my tab with branch 'test1', it correctly shows no more a working tree in this branch. All is ok.
6) After that, when I click on the other tab with the branch 'trunk', Bazaar Explorer encounters an error:
bzr: ERROR: (3, 'CreateFileW', 'Das System kann den angegebenen Pfad nicht finden.')
The relevant part of .bzr.log is:

1155.768 Traceback (most recent call last):
  File "C:/Program Files/Bazaar/plugins\explorer\lib\explorer.py", line 679, in changed_view
  File "C:/Program Files/Bazaar/plugins\explorer\lib\wt_browser.py", line 65, in set_tree
  File "C:/Program Files/Bazaar/plugins\explorer\lib\wt_browser.py", line 469, in set_tree
  File "C:/Program Files/Bazaar/plugins\explorer\lib\wt_browser.py", line 631, in set_tree
  File "C:/Users/abachmann/AppData/Roaming/bazaar/2.0/plugins\qbzr\lib\treewidget.py", line 1462, in set_tree
  File "C:/Users/abachmann/AppData/Roaming/bazaar/2.0/plugins\qbzr\lib\treewidget.py", line 415, in set_tree
  File "bzrlib\workingtree_4.pyo", line 581, in lock_read
  File "bzrlib\dirstate.pyo", line 3101, in lock_read
  File "bzrlib\lock.pyo", line 386, in __init__
  File "bzrlib\lock.pyo", line 366, in _open
error: (3, 'CreateFileW', 'Das System kann den angegebenen Pfad nicht finden.')

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers