bzr-explorer should depend on ssh-askpass

Bug #736436 reported by Chris Gagnon on 2011-03-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar Explorer
Medium
Unassigned
bzr-explorer (Ubuntu)
Medium
Andrew Starr-Bochicchio

Bug Description

Summary:
checkout and pull from a private ppa fails until ssh-askpass is installed

Steps to reproduce:
1. Install kubuntu 10.10
2. Install bzr-explorer 'sudo apt-get install bzr-explorer'
3. Open bzr-explorer
4. Setup and personalize bazaar
5. Select Get project source from elsewhere -> checkout
6. Enter the location of a private ppa 'lp:~<private ppa here>'
7. Enter the location of local directory to save checkout
8. Click ok

Expected results:
You are able checkout the private ppa

Actual results:
The checkout fails

Error log:
Error ssh_askpass: exec(/usr/bin/ssh-askpass): No such file or directory
Permission denied (publickey).
bzr: ERROR: Connection closed: Unexpected end of message. Please check connectivity and permissions, and report a bug if problems persist. :

Workaround:
open a terminal and type 'sudo apt-get install ssh-askpass' then retry the checkout

Changed in bzr-explorer:
status: New → Confirmed
Martin Pool (mbp) wrote :

You can't actually check out the source of a PPA as such, but that's tangential.

The main problem seems to be that bzr-explorer needs ssh-askpass to be installed, but it doesn't actually depend on it. It should, otherwise when run other than from a terminal it won't be able to open connections.

Changed in bzr-explorer:
importance: Undecided → Medium
summary: - checkout and pull from a private ppa fails
+ bzr-explorer should depend on ssh-askpass
Changed in bzr-explorer (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
tags: added: packaging ssh
Changed in bzr-explorer (Ubuntu):
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
status: Confirmed → In Progress

I never realized it, but apparently ubuntu-desktop pulls in ssh-askpass-gnome. Explains why I missed this. I'll get a fix into Debian and sync it over before Natty's release.

$ rdepends ssh-askpass-gnome
ssh-askpass-gnome
Reverse Depends:
  ubuntustudio-desktop
  ubuntu-sugar-remix
  ubuntu-chinese-desktop
 |sshmenu
  gstm
  ubuntu-desktop

Alexander Belchenko (bialix) wrote :

As I understand it, Bazaar Explorer has no direct dependency on ssh-askpass. So I don't think we have to fix anything in the explorer itself, right?

Changed in bzr-explorer:
status: Confirmed → Invalid

Right, I think this is only a packaging issue.

Sync request in Bug 738227.

Changed in bzr-explorer (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bzr-explorer - 1.1.2-2

---------------
bzr-explorer (1.1.2-2) unstable; urgency=low

  * debian/rules: Enable tests at build time.
  * debian/control:
   - Build depend on bzr, qbzr, python-testools,
     xvfb, and xauth.
   - Add Enhances: bzr
   - Recommend ssh-askpass (LP: #736436).
  * Transition from python-central to dh_python2
    (Closes: #616756).
  * Merge upstream rev 500 fixing test failure.
  * Move from CDBS to debhelper 7.
 -- Andrew Starr-Bochicchio <email address hidden> Sun, 20 Mar 2011 13:20:03 +0000

Changed in bzr-explorer (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers