Explorer crashes/locks on windows 7

Bug #717773 reported by Yuvalik on 2011-02-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bazaar Explorer
Medium
Unassigned
Bazaar Subversion Plugin
Undecided
Unassigned

Bug Description

Explorer fails to load/run properly. I just get an empty window which "stops responding" after a few seconds, and then I get the following error. I tried a clean install.

bzr: ERROR: subvertpy.SubversionException: ("Can't connect to host 'updates.isp-services.nl': A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. ", 730060)

Traceback (most recent call last):
  File "C:/Program Files/Bazaar/plugins\explorer\lib\explorer.py", line 1448, in callable_with_cleanup
  File "C:/Program Files/Bazaar/plugins\explorer\lib\explorer.py", line 1616, in _open_location_task
  File "C:/Program Files/Bazaar/plugins\explorer\lib\location_viewer.py", line 161, in add_location
  File "C:/Program Files/Bazaar/plugins\explorer\lib\location.py", line 178, in view
  File "C:/Program Files/Bazaar/plugins\explorer\lib\view_repository.py", line 272, in ui
  File "C:/Program Files/Bazaar/plugins\explorer\lib\view_repository.py", line 276, in refresh_view
  File "C:/Program Files/Bazaar/plugins\explorer\lib\view_repository.py", line 322, in _collect_data
  File "C:/Program Files/Bazaar/plugins\svn\workingtree.py", line 1186, in open_branch
  File "C:/Program Files/Bazaar/plugins\svn\workingtree.py", line 1195, in _open_branch
  File "C:/Program Files/Bazaar/plugins\svn\workingtree.py", line 1146, in _find_repository
  File "C:/Program Files/Bazaar/plugins\svn\errors.py", line 146, in convert
SubversionException: ("Can't connect to host 'updates.isp-services.nl': A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. ", 730060)

bzr 2.2.3 on python 2.6.4 (win32)
arguments: ['C:\\Program Files\\Bazaar\\tbzrcommand.exe', '--command=explorer', '--file=D:\\wamp\\www\\ZoekeenModel']
encoding: 'cp1252', fsenc: 'mbcs', lang: None
plugins:
  bzrtools C:\Program Files\Bazaar\plugins\bzrtools [2.2.0]
  colo C:\Program Files\Bazaar\plugins\colo [0.2.0]
  explorer C:\Program Files\Bazaar\plugins\explorer [1.1.2]
  fastimport C:\Program Files\Bazaar\plugins\fastimport [0.9.0dev]
  launchpad C:\Program Files\Bazaar\plugins\launchpad [2.2.3]
  loom C:\Program Files\Bazaar\plugins\loom [2.2.1dev]
  netrc_credential_store C:\Program Files\Bazaar\plugins\netrc_credential_store [2.2.3]
  news_merge C:\Program Files\Bazaar\plugins\news_merge [2.2.3]
  pipeline C:\Program Files\Bazaar\plugins\pipeline [1.1.0]
  qbzr C:\Program Files\Bazaar\plugins\qbzr [0.19.2]
  rewrite C:\Program Files\Bazaar\plugins\rewrite [0.6.1]
  svn C:\Program Files\Bazaar\plugins\svn [1.0.4]
  upload C:\Program Files\Bazaar\plugins\upload [1.0.0]
  xmloutput C:\Users\Bert\AppData\Roaming\bazaar\2.0\plugins\xmloutput [0.8.7.dev]

Jelmer Vernooij (jelmer) on 2011-02-26
Changed in bzr-explorer:
status: New → Confirmed
Changed in bzr-svn:
status: New → Fix Released
Changed in bzr-explorer:
importance: Undecided → Medium
tags: added: feel-faster multiprocess responsiveness
Gordon Tyler (doxxx) wrote :

Alex, I think there's another problem here in that the error is not being dealt with correctly. A connection failure should not be treated as a fatal error.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers