[master] bzr: ERROR: exceptions.TypeError: argument 1 of PyQt4.QtCore.QVariant() has an invalid type

Bug #650708 reported by Thomas Paine on 2010-09-28
206
This bug affects 28 people
Affects Status Importance Assigned to Milestone
Bazaar Explorer
Critical
Alexander Belchenko

Bug Description

User may get the following error while opening shared repository, new branch, File - Accessories or something else.
The distinctive message is shown in the first line:

--------------------------------------------------------------------
bzr: ERROR: exceptions.TypeError: argument 1 of PyQt4.QtCore.QVariant() has an invalid type

Traceback (most recent call last):
  File ".../plugins\explorer\lib\explorer.py", line 1450, in callable_with_cleanup
  File ".../plugins\explorer\lib\explorer.py", line 1618, in _open_location_task
  File ".../plugins\explorer\lib\location_viewer.py", line 161, in add_location
  File ".../plugins\explorer\lib\location.py", line 178, in view
  File ".../plugins\explorer\lib\view_repository.py", line 272, in ui
  File ".../plugins\explorer\lib\view_repository.py", line 277, in refresh_view
  File ".../plugins\explorer\lib\view_repository.py", line 287, in _update_view
  File ".../plugins\explorer\lib\view_repository.py", line 394, in _update_model
  File ".../plugins\explorer\widgets\conditional_dataview.py", line 109, in setData
  File ".../plugins\explorer\widgets\conditional_dataview.py", line 172, in set_raw_data
TypeError: argument 1 of PyQt4.QtCore.QVariant() has an invalid type
--------------------------------------------------------------------

**HOWTO FIX IT:**

* If you're get this error, please upgrade your Bazaar Explorer plugin to version 1.1.1.

* If you're using Windows Standalone Installer and you have Bazaar Explorer from that package, please download separate installer for newer Bazaar Explorer from the page: https://launchpad.net/bzr-explorer/+download and install this version.

Related branches

Thomas Paine (thomas-54) wrote :

I received the error again when I tried to "Open From Existing Location".

Thomas Paine (thomas-54) on 2010-09-28
description: updated
Thomas Paine (thomas-54) wrote :

Getting the same error if I try to create a new project in an empty folder. This is a fresh install of Bazaar using the windows installer.

OS: Windows 7 x64

Please let me know if you need more details.

Thomas Paine (thomas-54) on 2010-09-28
description: updated
Thomas Paine (thomas-54) on 2010-09-29
summary: - Crashed after creating new repository with existing code
+ Crashes when trying to open project
description: updated

Resolved by reverting to version 1.0.2 of the Explorer plugin.

Alexander Belchenko (bialix) wrote :

I can't confirm your problem on Windows XP.

It seems you have some problem with PyQt and 64-bit system.

Alexander Belchenko (bialix) wrote :

If you want to help to debug this problem (because I have no Win7 x64 system around), then please insert this line before line 172 in C:/Program Files (x86)/Bazaar/plugins\explorer\widgets\conditional_dataview.py file (of bzr-explorer v.1.1):

                        print i, j, `tuple_list[i][j]`

Then start bzr-explorer from command line as `bzr explorer`. After that try to reproduce this problem again and then show output in the console.

And it seems you have different settings in explorer. Please tell us what explorer settings you're using.

Changed in bzr-explorer:
status: New → Incomplete
Changed in bzr-explorer:
importance: Undecided → Critical
milestone: none → 1.1.1
Alexander Belchenko (bialix) wrote :

To reproduce:

bzr init-repo repo
cd repo
bzr init trunk
bzr explorer .

The crash occurs because explorer tries to add Python None value as QVariant.

Changed in bzr-explorer:
status: Incomplete → Confirmed
assignee: nobody → Alexander Belchenko (bialix)
status: Confirmed → In Progress
Alexander Belchenko (bialix) wrote :

The problem fixed in lp:bzr-explorer and new release of Bazaar Explorer will follow soon.

Changed in bzr-explorer:
status: In Progress → Fix Released
Alexander Belchenko (bialix) wrote :

@Gary van der Merwe: if you by any chance will build new windows installer I'd like to have this fix in. Otherwise I just release explorer 1.1.1 soon and provide usual small installer for explorer.

Wow, 3 bugs reports about the same problem as of today.
/me scratches head

Thank you for the very quick resolution. I'm new to Bazaar and this initial bug left me feeling nervous about my choice to move the organization to it. Your quick response and remedy has, however, restored my faith. I look forward to testing out the new version when you release it.

Thomas Paine пишет:
> Thank you for the very quick resolution. I'm new to Bazaar and this
> initial bug left me feeling nervous about my choice to move the
> organization to it. Your quick response and remedy has, however,
> restored my faith. I look forward to testing out the new version when
> you release it.

You already can test it. Just get a code from launchpad as

bzr branch lp:bzr-explorer explorer

and then put it into your Bazaar plugins folder.

Or you can wait couple of days for release.
In the meantime you should open the branch directly. E.g. you have on
your disk:

C:\work\repo
C:\work\repo\trunk

Opening repo will fail with this bug, but opening the trunk will
succeed. Trunk is where your working files is.

Amir Shenouda (amir-samy) wrote :
Download full text (3.6 KiB)

3 is few, I just downloaded it today and after less than 1 min of opening it
I faced it ;)

--------------------------------------------------
From: "Alexander Belchenko" <email address hidden>
Sent: Wednesday, September 29, 2010 6:12 PM
To: <email address hidden>
Subject: Re: [Bug 650708] Re: Crashes when trying to open project

> Wow, 3 bugs reports about the same problem as of today.
> /me scratches head
>
> --
> Crashes when trying to open project
> https://bugs.launchpad.net/bugs/650708
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (651160).
>
> Status in Bazaar Explorer: Fix Released
>
> Bug description:
> Attempting to Create new Project or Initialize a new project with an
> existing code base.
>
> Workspace Model: Feature Branches
> Options: "Move existing files"
>
> OS: Windows 7 x64
> Hardware: HP Pavilion Elite HPE
>
> Error:
>
> bzr: ERROR: exceptions.TypeError: argument 1 of PyQt4.QtCore.QVariant()
> has an invalid type
>
> Traceback (most recent call last):
> File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\explorer.py",
> line 1450, in callable_with_cleanup
> File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\explorer.py",
> line 1618, in _open_location_task
> File "C:/Program Files
> (x86)/Bazaar/plugins\explorer\lib\location_viewer.py", line 161, in
> add_location
> File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\location.py",
> line 178, in view
> File "C:/Program Files
> (x86)/Bazaar/plugins\explorer\lib\view_repository.py", line 272, in ui
> File "C:/Program Files
> (x86)/Bazaar/plugins\explorer\lib\view_repository.py", line 277, in
> refresh_view
> File "C:/Program Files
> (x86)/Bazaar/plugins\explorer\lib\view_repository.py", line 287, in
> _update_view
> File "C:/Program Files
> (x86)/Bazaar/plugins\explorer\lib\view_repository.py", line 394, in
> _update_model
> File "C:/Program Files
> (x86)/Bazaar/plugins\explorer\widgets\conditional_dataview.py", line 109,
> in setData
> File "C:/Program Files
> (x86)/Bazaar/plugins\explorer\widgets\conditional_dataview.py", line 172,
> in set_raw_data
> TypeError: argument 1 of PyQt4.QtCore.QVariant() has an invalid type
>
> bzr 2.2.1 on python 2.6.4 (win32)
> arguments: ['C:\\Program Files (x86)\\Bazaar\\bzrw.exe', 'explorer']
> encoding: 'cp1252', fsenc: 'mbcs', lang: None
> plugins:
> bzrtools C:\Program Files (x86)\Bazaar\plugins\bzrtools
> [2.2.0]
> colo C:\Program Files (x86)\Bazaar\plugins\colo [0.1.0]
> explorer C:\Program Files (x86)\Bazaar\plugins\explorer
> [1.1.0]
> fastimport C:\Program Files (x86)\Bazaar\plugins\fastimport
> [0.9.0dev]
> launchpad C:\Program Files (x86)\Bazaar\plugins\launchpad
> [2.2.1]
> loom C:\Program Files (x86)\Bazaar\plugins\loom
> [2.2.1dev]
> netrc_credential_store C:\Program Files
> (x86)\Bazaar\plugins\netrc_credential_store [2.2.1]
> news_merge C:\Program Files (x86)\Bazaar\plugins\news_merge
> [2.2.1]
> pipeline C:\Program Files (x86)\Bazaar\plugins\pipeline
> [unknown]
> qbzr C:\Program Files ...

Read more...

summary: - Crashes when trying to open project
+ [master] bzr: ERROR: exceptions.TypeError: argument 1 of
+ PyQt4.QtCore.QVariant() has an invalid type
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
description: updated

Thanks!

A note: I have Bazaar installed using Windows Standalone Installer 2.2.1, so I followed your instruction to update my Explorer Plug-in. The first time however, after runinng the Explorer 1.1.1 installer, I got error message about "bzr.exe not found" when I tried to run Explorer.

I was able to resolve the problem by:
* Un-installing everything Bazaar related
* Installing Bazaar 2.2.1 stand-alone installer
* Installing Explorer 1.1.1 using the installer, but DESELECTING the "Create Start Menu shortcuts" and "Quick Launch Icon".

It seems that the Explorer 1.1.1 installer creates shortcuts to Explorer that don't work the way the Bazaar installer shortcuts do.

Adam Nofsinger пишет:
> Thanks!
>
> A note: I have Bazaar installed using Windows Standalone Installer
> 2.2.1, so I followed your instruction to update my Explorer Plug-in. The
> first time however, after runinng the Explorer 1.1.1 installer, I got
> error message about "bzr.exe not found" when I tried to run Explorer.
>
> I was able to resolve the problem by:
> * Un-installing everything Bazaar related
> * Installing Bazaar 2.2.1 stand-alone installer
> * Installing Explorer 1.1.1 using the installer, but DESELECTING the "Create Start Menu shortcuts" and "Quick Launch Icon".
>
> It seems that the Explorer 1.1.1 installer creates shortcuts to Explorer
> that don't work the way the Bazaar installer shortcuts do.

Thank you for testing our installer! I was not aware of this problem.
Can you file a separate bug about Explorer installer problems, please?

description: updated
VAlexiev (vladimir-sirma-bg) wrote :

I got the error while doing Bazaar>Tools>Initialze (control-N). Will try with explorer 1.1. now

Gary van der Merwe (garyvdm) wrote :

bzr-2.2.1-3-setup.exe with a fix for this bug included is now available:
http://edge.launchpad.net/bzr/2.2/2.2.1/+download/bzr-2.2.1-3-setup.exe

Alex L. (alexal) wrote :

I confirm that is this build the issue was resolved.

cowboy (xynf22amhc) wrote :

it works well with windows 7(x64,ja).

thank you.

Happy new year

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers