bzr explorer always terminates with segmentation fault

Bug #585775 reported by Russel Winder on 2010-05-26
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Bazaar Explorer
Medium
Unassigned

Bug Description

I am finding that "bzr explorer" always terminates with a segmentation fault. I am using bzr.dev kept up to date daily and branches of all plugins, again kept up to date daily. I'll attach an apport report once I have the bug number. I ran under strace and below is the tail end of the output:

poll([{fd=8, events=POLLIN}], 1, -1) = 1 ([{fd=8, revents=POLLIN}])
read(8, "\34\0\332\23\234\1\340\6<\1\0\0\322',7\1\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 4096) = 64
read(8, 0x29983b4, 4096) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=8, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=8, revents=POLLOUT}])
writev(8, [{"\24\0\6\0\234\1\340\6<\1\0\0<\1\0\0\0\0\0\0\2\0\0\0", 24}, {NULL, 0}, {"", 0}], 3) = 24
poll([{fd=8, events=POLLIN}], 1, -1) = 1 ([{fd=8, revents=POLLIN}])
read(8, "\1\0\334\23\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0", 4096) = 32
read(8, 0x29983b4, 4096) = -1 EAGAIN (Resource temporarily unavailable)
uname({sys="Linux", node="anglides", ...}) = 0
poll([{fd=8, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=8, revents=POLLOUT}])
writev(8, [{"\230\7\2\0\274\1\340\0066\1\2\0\273\1\340\6<\0\2\0\275\1\340\6\230\7\2\0\3\0\340\6"..., 908}, {NULL, 0}, {"", 0}], 3) = 908
poll([{fd=8, events=POLLIN}], 1, -1) = 1 ([{fd=8, revents=POLLIN}])
read(8, "\34\0\346\23G\3\340\6\215\1\0\0\324',7\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 4096) = 708
read(8, 0x29983b4, 4096) = -1 EAGAIN (Resource temporarily unavailable)
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++
Segmentation fault

Russel Winder (russel) wrote :

"apport-collect 585775" returns "no additional information to collect", so I clearly have no clue about apport :-(

I am using a twin-Xeon workstation running Lucid AMD64 fully up to date.

|> bzr plugins
bash_completion 2.2.0dev1
   Generate a shell function for bash command line completion.

bookmarks
   Bazaar Bookmarks

builddeb 2.2.0
   bzr-builddeb - manage packages in a Bazaar branch.

bzrtools 2.2.0
   Various useful commands for working with bzr.

dbus 0.1.0dev
   D-Bus integration for bzr/bzrlib.

diffstat 0.2.0
   diffstat - show stats about changes to the working tree

email
   Sending emails for commits and branch changes.

explorer 1.1.0dev
   Version Control for Human Beings.

fastimport 0.9.0dev
   FastImport Plugin

git 0.5.1
   A GIT branch and repository format implementation for bzr.

gtk 0.99.0dev1
   Graphical support for Bazaar using GTK.

hg 0.2.0dev
   Mercurial support for Bazaar.

launchpad 2.2.0dev1
   Launchpad.net integration plugin for Bazaar.

loggerhead 1.17.0
   Loggerhead web viewer for Bazaar branches.

loom 2.1.1dev
   Loom is a bzr plugin which adds new commands to manage a loom of patches.

netrc_credential_store 2.2.0dev1
   Use ~/.netrc as a credential store for authentication.conf.

news_merge 2.2.0dev1
   Merge hook for bzr's NEWS file.

pipeline
   Manage a series of branches as a pipeline.

pqm 1.4.0dev
   Functionality for controlling a Patch Queue Manager (pqm).

qbzr 0.19.0dev1
   QBzr - Qt-based frontend for Bazaar

rebase
   (no description)

rewrite 0.6.1dev
   Rebase support.

scmproj 0.6.1
   Organise and manage a collection of bzr branches as a complex project.

search 1.7.0dev
   search is a bzr plugin for searching bzr content.

stats 0.1.0dev
   A Simple bzr plugin to generate statistics about the history.

svn 1.0.3dev
   Support for Subversion branches

upload 1.0.0dev
   Upload a working tree, incrementally.

xmloutput 0.8.7.dev
   This plugin adds an option (--xml) to log and provides an xml version of some builtin commands.

Changed in bzr-explorer:
importance: Undecided → Medium
status: New → Confirmed
Martitza (martitzam) wrote :

I see an equivalent strace with this setup:

bzr 2.2b4
qbzr 0.19
explorer 1.10b1
ubuntu 10.04

Niraj Dudani (nirajdude) wrote :

I am using bzr explorer from the stable PPA. I get a similar strace too.

Version information:
Ubuntu 10.04.1

Bazaar (bzr) 2.1.1
  Python interpreter: /usr/bin/python 2.6.5
  Python standard library: /usr/lib/python2.6
  Platform: Linux-2.6.32-25-generic-i686-with-Ubuntu-10.04-lucid
  bzrlib: /usr/lib/python2.6/dist-packages/bzrlib

Bazaar Explorer Version 1.1.0 "Bartolomeu Dias"

QBzr 0.19.2, bzrlib 2.2.1, PyQt 4.7.2, Qt 4.6.2, Python 2.6.5

bash_completion 2.2.1
   Generate a shell function for bash command line completion.

bzrtools 2.2.0
   Various useful commands for working with bzr.

dbus 0.1.0dev
   D-Bus integration for bzr/bzrlib.

explorer 1.1.0
   Version Control for Human Beings.

gtk 0.99.0
   Graphical support for Bazaar using GTK.

launchpad 2.2.1
   Launchpad.net integration plugin for Bazaar.

netrc_credential_store 2.2.1
   Use ~/.netrc as a credential store for authentication.conf.

news_merge 2.2.1
   Merge hook for bzr's NEWS file.

qbzr 0.19.2
   QBzr - Qt-based frontend for Bazaar

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers