Opening Preferences: bzr: ERROR: exceptions.AttributeError: 'module' object has no attribute 'QFormLayout'

Bug #429549 reported by Klaus Rennecke on 2009-09-14
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Bazaar Explorer
Low
Unassigned
QBzr
Undecided
Unassigned

Bug Description

Steps to repeat:
On: Ubuntu 8.04.3 LTS x86_64
Branch: lp:bzr-explorer to ~/bazaar/plugins (revision <email address hidden>)
Install: apt-get install python-qt4
Start: bzr explorer (in a repository)
Click: Edit/Preferences

Traceback (most recent call last):
  File "/home/kre/.bazaar/plugins/explorer/lib/explorer.py", line 1279, in do_preferences
    self._preferences, self._preference_changed, title, self)
  File "/home/kre/.bazaar/plugins/explorer/lib/explorer_preferences.py", line 106, in __init__
    self._build_ui(title)
  File "/home/kre/.bazaar/plugins/explorer/lib/explorer_preferences.py", line 118, in _build_ui
    layout.addWidget(self._build_applications_section())
  File "/home/kre/.bazaar/plugins/explorer/lib/explorer_preferences.py", line 128, in _build_applications_section
    layout = QtGui.QFormLayout()
AttributeError: 'module' object has no attribute 'QFormLayout'

bzr 1.18 on python 2.5.2 (linux2)
arguments: ['/usr/bin/bzr', 'explorer']
encoding: 'UTF-8', fsenc: 'UTF-8', lang: 'de_DE.UTF-8'
plugins:
  bzrtools /usr/lib/python2.5/site-packages/bzrlib/plugins/bzrtools [1.18]
  explorer /home/kre/.bazaar/plugins/explorer [0.8]
  fastimport /home/kre/.bazaar/plugins/fastimport [0.9dev]
  gtk /usr/lib/python2.5/site-packages/bzrlib/plugins/gtk [0.97.0.final]
  launchpad /usr/lib/python2.5/site-packages/bzrlib/plugins/launchpad [1.18]
  netrc_credential_store /usr/lib/python2.5/site-packages/bzrlib/plugins/netrc_credential_store [1.18]
  qbzr /home/kre/.bazaar/plugins/qbzr [0.15dev]
  svn /home/kre/.bazaar/plugins/svn [0.6.5]

Klaus Rennecke пишет:
> Public bug reported:
>
> Steps to repeat:
> On: Ubuntu 8.04.3 LTS x86_64
> Branch: lp:bzr-explorer to ~/bazaar/plugins (revision <email address hidden>)
> Install: apt-get install python-qt4
> Start: bzr explorer (in a repository)
> Click: Edit/Preferences
>
> AttributeError: 'module' object has no attribute 'QFormLayout'

You have installed Qt/PyQT version 4.3 or earlier. bzr-explorer requires Qt/PyQt version 4.4 or higher.

Klaus Rennecke (kre) wrote :

Oh that's unfortunate. Note that it will probably be hard for any users of the current Ubuntu LTS release to use the explorer then. See also: http://packages.ubuntu.com/hardy-updates/python-qt4

Ian Clatworthy (ian-clatworthy) wrote :

It's certainly a shame if this discourages those on hardy to use explorer. 90%+ of the dialogs ought to work IIUIC so maybe it's worth tweaking this one to not use QFormLayout.

Changed in bzr-explorer:
importance: Undecided → Low
status: New → Confirmed
Alexander Belchenko (bialix) wrote :

Ian, QBzr will be affected by this too. Because we declared to drop support for Qt < 4.4 in the July. And we have long discussion in QBzr ML prior.

Gary van der Merwe (garyvdm) wrote :

For qbzr, you can either use a older version of qbzr , or if you want the latest qbzr, please upgrade your Qt version.

Changed in qbzr:
status: New → Won't Fix
Ian Clatworthy (ian-clatworthy) wrote :

Yes, I'd prefer moving to a more recent Qt rather than supporting the one in Hardy.

Changed in bzr-explorer:
status: Confirmed → Won't Fix
Klaus Rennecke (kre) wrote :

Well, Lucid won't be long now so a LTS version is on the horizon that would enable users to update their Qt.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers