smtp_connection.py fails to import BzrCommandError exception

Bug #224202 reported by scottwilson on 2008-04-29
4
Affects Status Importance Assigned to Milestone
bzr email commit hook
High
scottwilson

Bug Description

trivial, missing an import statement causing traceback on smtp config problems.

Related branches

scottwilson (scott-idealist) wrote :
John A Meinel (jameinel) wrote :

Thanks

I went ahead and fixed it in a different way. Specifically, we generally prefer to use:

errors.BzrCommandError

and we had already imported "errors" into the file.

This should be present in trunk revno 31, which I'm guessing will make the next release. (I don't package bzr-email, so I'm not sure)

Changed in bzr-email:
assignee: nobody → scott-idealist
importance: Undecided → High
status: New → Fix Released
Renato Silva (renatosilva) wrote :

I tried to use an smtp server which does not require authentication (works with a PHP script for example), and it gives me an error on starttls() call, which is not captured by the except block: http://bazaar.launchpad.net/~bzr/bzr-email/trunk/revision/40.

I don't have the error message at the moment, but I had to comment out the whole try/except block to make it work.

Renato Silva (renatosilva) wrote :

Maybe this bug should be re-opened?

On Wed, 2009-06-17 at 06:07 +0000, Renato Silva wrote:
> Maybe this bug should be re-opened?

This bug is about an import error, not TLS.

-Rob

Renato Silva (renatosilva) wrote :

Ok, I think I'll try to find the message later and open another bug, thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers