"Bazaar import wizard" prompts are not easily understood

Bug #372535 reported by Robin Sheat on 2009-05-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Bazaar Plugin for Eclipse
Medium
Alexander Taler

Bug Description

When you 'branch as a new project' the dialogue says 'Select the source branch', and the options are 'Initialize a new branch location' and 'Use existing branch location'. As a relatively new user to bzr and the eclipse plugin, I have no idea what this means. I'm trying to branch from a remote repository, so I guess I 'use existing branch location'. But then 'next' and 'finish' vanish. 'Initialize' is my only option.

And then, a step or two later, I can't go 'next' or 'finish' anyway. Only back or cancel.

Note that I'm using the latest trunk, so I may be hitting incomplete features, but please consider putting a bit of context help in the dialogues. It's not usually clear what the prompts mean.

Guillermo Gonzalez (verterok) wrote :

Thanks for reporting this!
Sure, bzr-eclipse should provide context help in the wizard using the embedded help or at least via tooltips

Changed in bzr-eclipse:
importance: Undecided → Medium
status: New → Confirmed
Ian Clatworthy (ian-clatworthy) wrote :

I find this wizard confusing as well. I expected to see a text field (one line) that I can enter a URL on. Ideally some sample URLs would be given below that text field and previous values would be selectable and editable. What exactly is the current control there for? I can't enter anything in there.

Hi Ian,

On Fri, May 29, 2009 at 3:25 PM, Ian Clatworthy
<email address hidden> wrote:
> I find this wizard confusing as well. I expected to see a text field
> (one line) that I can enter a URL on. Ideally some sample URLs would be
> given below that text field and previous values would be selectable and
> editable. What exactly is the current control there for? I can't enter
> anything in there.

That's a good idea.

The control should show your previously entered branches, but I think
it can be removed an use a combo box (and a single wizard page) for
the same.

>
> --
> "Bazaar import wizard" prompts are not easily understood
> https://bugs.launchpad.net/bugs/372535
> You received this bug notification because you are a member of bzr-
> eclipse developers, which is subscribed to Bazaar Plugin for Eclipse.
>
> Status in Bazaar Plugin for Eclipse: Confirmed
>
> Bug description:
> When you 'branch as a new project' the dialogue says 'Select the source branch', and the options are 'Initialize a new branch location' and 'Use existing branch location'. As a relatively new user to bzr and the eclipse plugin, I have no idea what this means. I'm trying to branch from a remote repository, so I guess I 'use existing branch location'. But then 'next' and 'finish' vanish. 'Initialize' is my only option.
>
> And then, a step or two later, I can't go 'next' or 'finish' anyway. Only back or cancel.
>
> Note that I'm using the latest trunk, so I may be hitting incomplete features, but please consider putting a bit of context help in the dialogues. It's not usually clear what the prompts mean.
>

Thanks,

Best regards.

--
Guillermo Gonzalez
<http://launchpad.net/~verterok>

Richard Gruet (rgruet) wrote :

As of Feb 2010, I ran into exactly the same problem when trying to check out a project via New project.. > Bazaar > Checkout as new project.

If I pick "Use existing branch location", the "Next" button becomes disabled.

If I pick "Initialize a new branch location", then select the path of the source branch: If I enter a Windows path (with \) the "Next" button is disabled. I have to replace the '\' with '/' to get the "Next" enabled. Maybe you should replace '\' with '/' automatically?

Then I choose "Create a project" > Next, and enter a project name (say "myProject"). By default the "use default location" is disabled, and the Location field contains <path-to-my-eclipse-workspace>\myProject. This is perfect, unfortunately the "Next" and "Finish" buttons are disabled! And if I uncheck "Use default location", and try to manually enter <path-to-my-eclipse-workspace>\myProject in the Location field, I get an error message at the top, saying "<path-to-my-eclipse-workspace>\myProject overlaps the location of another project: 'myProject', which is absurd, so I am stuck. Paths within my Eclipse workspace produce the aforementioned error, paths outside don't. But in any case, whatever path I enter, the "Next" and "Finish" buttons stay disabled.

So the wizard is desperatly useless for me...

I'm using Eclipse 3.5, bzr-eclipse 1.1.210, Bazaar 2.0.2, and xml-output 0.8.4.

Cheers

Richard

Richard Gruet (rgruet) wrote :

[update March 1st] - I tried to use the wizard again from Windows, but this time with a repository on Linux and a bzr+ssh protocol to access it, and... it worked perfectly! From which I infer that the problem I reported earlier only occurs with windows paths.

More specifically, the repository was on a Windows shared directory, mapped to a drive letter, and the path included some spaces, so the path to the repository looked like "W:\path to\somewhere on the\shared\directory". Don't know if it helps to find the cause of the problem...

Richard

Guillermo Gonzalez (verterok) wrote :

Hi RIchard,

Yes, there are aome problems handling windows paths, see Bug #314893

Regarding this, I have been playing a bit with the branch wizard to make it simpler, so the import wizard will be the next one.

Regards,

wgodoy80 (wgodoy80) wrote :

Hi Guillermo,

When I use a Linux computer I have no problem to branch a project with either Eclipse or directly from terminal ($ bzr branch lp~/location ) . When I try to get the same branch in Windows it doesn't work with either Eclipse (I installed xmlout and bzr-eclipse plugins , but it freezes) or the BZR Explorer which returns the following error message after fetching some stuff:

bzr: ERROR: [Errno 2] No such file or directory: u'C:/Users/wgodoy/workspace/DOPAT/trunk/.bzr/checkout/limbo/new-6/Functions /Complex.java'

Looks similar to Richard's problem (#5) with windows paths. Hope this helps. Thanks.

Alexander Taler (alex-idereal) wrote :

I have completely reimplemented the project creation wizard(s) on my branch. Hopefully this will be available in the next release.

Changed in bzr-eclipse:
milestone: none → 1.2
Changed in bzr-eclipse:
assignee: nobody → Alexander Taler (alex-idereal)
status: Confirmed → Fix Committed
Changed in bzr-eclipse:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers