NullPointerException in share project wizard using Eclipse from https://launchpad.net/~eclipse-team/+archive

Bug #320645 reported by Michaël Vanderheeren on 2009-01-23
2
Affects Status Importance Assigned to Milestone
Bazaar Plugin for Eclipse
Undecided
Unassigned

Bug Description

I still get error's when trying to share a project

!SESSION 2009-01-23 21:59:18.104 -----------------------------------------------
eclipse.buildId=I20080617-2000
java.fullversion=GNU libgcj 4.3.2
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=nl_BE
Framework arguments:
Command-line arguments: -os linux -ws gtk -arch x86

!ENTRY org.eclipse.equinox.p2.ui.sdk 2 0 2009-01-23 21:59:25.177
!MESSAGE Could not locate the running profile instance

!ENTRY org.eclipse.team.core 2 0 2009-01-23 22:00:14.034
!MESSAGE Meta files for two repository types (org.tigris.subversion.subclipse.core.svnnature and org.vcs.bazaar.eclipse.core.repository.BazaarTeamProvider was found in project jTouch.

!ENTRY org.eclipse.ui 4 0 2009-01-23 22:00:31.478
!MESSAGE Unhandled event loop exception
!STACK 0
java.lang.NullPointerException
   at org.vcs.bazaar.eclipse.core.utils.ResourceUtil.findRootLocation(ResourceUtil.java:49)
   at org.vcs.bazaar.eclipse.internal.core.model.ProjectBranch.getPath(ProjectBranch.java:69)
   at org.vcs.bazaar.eclipse.internal.core.model.ProjectBranch.getLocation(ProjectBranch.java:64)
   at org.vcs.bazaar.eclipse.internal.core.model.LocalBranch.<init>(LocalBranch.java:49)
   at org.vcs.bazaar.eclipse.internal.core.model.ProjectBranch.<init>(ProjectBranch.java:48)
   at org.vcs.bazaar.eclipse.BzrWorkspaceRoot.<init>(BzrWorkspaceRoot.java:52)
   at org.vcs.bazaar.eclipse.core.repository.BazaarTeamProvider.setProject(BazaarTeamProvider.java:78)
   at org.eclipse.team.core.RepositoryProvider.mapNewProvider(org.eclipse.team.core_3.4.0.I20080605.jar.so)
   at org.eclipse.team.core.RepositoryProvider.map(org.eclipse.team.core_3.4.0.I20080605.jar.so)
   at org.vcs.bazaar.eclipse.core.repository.BazaarTeamProvider.registerProject(BazaarTeamProvider.java:44)
   at org.vcs.bazaar.eclipse.ui.wizards.configuration.BazaarConfigurationWizard.performFinish(BazaarConfigurationWizard.java:54)
   at org.eclipse.jface.wizard.WizardDialog.finishPressed(org.eclipse.jface_3.4.0.I20080606-1300.jar.so)
   at org.eclipse.jface.wizard.WizardDialog.buttonPressed(org.eclipse.jface_3.4.0.I20080606-1300.jar.so)
   at org.eclipse.jface.dialogs.Dialog$2.widgetSelected(org.eclipse.jface_3.4.0.I20080606-1300.jar.so)
   at org.eclipse.swt.widgets.TypedListener.handleEvent(org.eclipse.swt.gtk.linux.x86_3.4.0.v3448f.jar.so)
   at org.eclipse.swt.widgets.EventTable.sendEvent(org.eclipse.swt.gtk.linux.x86_3.4.0.v3448f.jar.so)
   at org.eclipse.swt.widgets.Widget.sendEvent(org.eclipse.swt.gtk.linux.x86_3.4.0.v3448f.jar.so)
   at org.eclipse.swt.widgets.Display.runDeferredEvents(org.eclipse.swt.gtk.linux.x86_3.4.0.v3448f.jar.so)
   at org.eclipse.swt.widgets.Display.readAndDispatch(org.eclipse.swt.gtk.linux.x86_3.4.0.v3448f.jar.so)
   at org.eclipse.jface.window.Window.runEventLoop(org.eclipse.jface_3.4.0.I20080606-1300.jar.so)
   at org.eclipse.jface.window.Window.open(org.eclipse.jface_3.4.0.I20080606-1300.jar.so)
   at org.eclipse.team.internal.ui.wizards.ConfigureProjectWizard.openWizard(org.eclipse.team.ui_3.4.0.I20080604.jar.so)
   at org.eclipse.team.internal.ui.wizards.ConfigureProjectWizard.shareProjects(org.eclipse.team.ui_3.4.0.I20080604.jar.so)
   at org.eclipse.team.internal.ui.actions.ConfigureProjectAction$1.run(org.eclipse.team.ui_3.4.0.I20080604.jar.so)
   at org.eclipse.team.internal.ui.actions.TeamAction$3.run(org.eclipse.team.ui_3.4.0.I20080604.jar.so)
   at org.eclipse.swt.custom.BusyIndicator.showWhile(org.eclipse.swt.gtk.linux.x86_3.4.0.v3448f.jar.so)
   at org.eclipse.team.internal.ui.actions.TeamAction.run(org.eclipse.team.ui_3.4.0.I20080604.jar.so)
   at org.eclipse.team.internal.ui.actions.ConfigureProjectAction.execute(org.eclipse.team.ui_3.4.0.I20080604.jar.so)
   at org.eclipse.team.internal.ui.actions.TeamAction.run(org.eclipse.team.ui_3.4.0.I20080604.jar.so)
   at org.eclipse.team.internal.ui.actions.TeamAction.runWithEvent(org.eclipse.team.ui_3.4.0.I20080604.jar.so)
   at org.eclipse.ui.internal.PluginAction.runWithEvent(org.eclipse.ui.workbench_3.4.0.I20080606-1300.jar.so)
   at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(org.eclipse.jface_3.4.0.I20080606-1300.jar.so)
   at org.eclipse.jface.action.ActionContributionItem.access$2(org.eclipse.jface_3.4.0.I20080606-1300.jar.so)
   at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(org.eclipse.jface_3.4.0.I20080606-1300.jar.so)
   at org.eclipse.swt.widgets.EventTable.sendEvent(org.eclipse.swt.gtk.linux.x86_3.4.0.v3448f.jar.so)
   at org.eclipse.swt.widgets.Widget.sendEvent(org.eclipse.swt.gtk.linux.x86_3.4.0.v3448f.jar.so)
   at org.eclipse.swt.widgets.Display.runDeferredEvents(org.eclipse.swt.gtk.linux.x86_3.4.0.v3448f.jar.so)
   at org.eclipse.swt.widgets.Display.readAndDispatch(org.eclipse.swt.gtk.linux.x86_3.4.0.v3448f.jar.so)
   at org.eclipse.ui.internal.Workbench.runEventLoop(org.eclipse.ui.workbench_3.4.0.I20080606-1300.jar.so)
   at org.eclipse.ui.internal.Workbench.runUI(org.eclipse.ui.workbench_3.4.0.I20080606-1300.jar.so)
   at org.eclipse.ui.internal.Workbench.access$4(org.eclipse.ui.workbench_3.4.0.I20080606-1300.jar.so)
   at org.eclipse.ui.internal.Workbench$5.run(org.eclipse.ui.workbench_3.4.0.I20080606-1300.jar.so)
   at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:288)
   at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(org.eclipse.ui.workbench_3.4.0.I20080606-1300.jar.so)
   at org.eclipse.ui.PlatformUI.createAndRunWorkbench(org.eclipse.ui.workbench_3.4.0.I20080606-1300.jar.so)
   at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:113)
   at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:193)
   at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(org.eclipse.osgi_3.4.0.v20080605-1900.jar.so)
   at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(org.eclipse.osgi_3.4.0.v20080605-1900.jar.so)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(org.eclipse.osgi_3.4.0.v20080605-1900.jar.so)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run(org.eclipse.osgi_3.4.0.v20080605-1900.jar.so)
   at java.lang.reflect.Method.invoke(libgcj.so.90)
   at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
   at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
   at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
   at org.eclipse.equinox.launcher.Main.main(Main.java:1212)

Guillermo Gonzalez (verterok) wrote :

Could you give a brief explanation of the steps to reproduce this error?

Thanks!

Check out a branch with the bzr command in the command line. Import as project or create new project with that folder. Right click the project name. Click team. You see "apply patch" and "share project". Click the last one. Fill in the details. I've clicked on use existing .bzr. Then i clicked finish. It was doing some Init. That ended, and the screen did not close...

Guillermo Gonzalez (verterok) wrote :

I just commented on this in the (now) linked Question #57297

I just tested this two ways of importing and both worked.

looks like something is wrong with your config or as you mentioned with that version eclipse .

I'm using:
Eclipse: 3.4.1 - Build id: M20080911-1700
Bazaar: 1.10
xmloutput: 0.8.2

Looks like it. Will try a stand-alone version. Pitty it doesn't work with the .deb. Sorry for all the bogus questions and bugs. Will close this when tested with the stand-alone version. Thanks for the work!

Guillermo Gonzalez (verterok) wrote :

too bad :(
I'll try to debug this with the eclipse from the ppa as soon I get home.
There's nothing to sorry about :)
I'll try to debug this, and if it's caused by the debs, then I'll link this bug to the package.

Changed in bzr-eclipse:
status: New → Triaged

Works with stand-alone. Bug is due to usage https://launchpad.net/~eclipse-team/+archive

Guillermo Gonzalez (verterok) wrote :

Oh, great to know.
I'll change the title of the bug, to reflect this

Thanks!

Changed in bzr-eclipse:
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions